This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1021040 - Could not resolve dependencies for project demo/multiApp mvn exec:java
Could not resolve dependencies for project demo/multiApp mvn exec:java
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: kconner
Jiri Sedlacek
:
Depends On:
Blocks: 1016660 1018861
  Show dependency treegraph
 
Reported: 2013-10-18 16:23 EDT by ppecka
Modified: 2015-08-02 19:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 13:23:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ppecka: needinfo-


Attachments (Terms of Use)

  None (edit)
Description ppecka 2013-10-18 16:23:30 EDT
Description of problem:
demo/multiApp 
follow steps from https://bugzilla.redhat.com/show_bug.cgi?id=1016660

mvn exec:java
[INFO] Scanning for projects...
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Quickstart Demo: Multiple Applications - Order Consumer 1.1.0.M3-redhat-2
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] >>> exec-maven-plugin:1.2.1-redhat-1:java (default-cli) @ switchyard-quickstart-demo-multi-order-consumer >>>
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 4.114s
[INFO] Finished at: Fri Oct 18 22:19:55 CEST 2013
[INFO] Final Memory: 56M/493M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project switchyard-quickstart-demo-multi-order-consumer: Could not resolve dependencies for project org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-order-consumer:jar:1.1.0.M3-redhat-2: Failed to collect dependencies for [org.switchyard:switchyard-api:jar:1.1.0.M3-redhat-2 (compile), org.switchyard:switchyard-plugin:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-bean:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-camel-core:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.components:switchyard-component-soap:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:1.1.0.M3-redhat-2 (compile), org.hornetq:hornetq-core-client:jar:2.3.1.Final-redhat-1 (compile), javax.jms:jms:jar:1.1 (compile), org.switchyard:switchyard-test:jar:1.1.0.M3-redhat-2 (test), org.switchyard.components:switchyard-component-test-mixin-hornetq:jar:1.1.0.M3-redhat-2 (test), junit:junit:jar:4.10-redhat-2 (test)]: Failed to read artifact descriptor for org.switchyard.quickstarts.demos:switchyard-quickstart-demo-multi-artifacts:jar:1.1.0.M3-redhat-2: Failure to find org.switchyard.quickstarts:switchyard-quickstart-parent:pom:1.1.0.M3-redhat-2 in http://maven.repository.redhat.com/techpreview/all/ was cached in the local repository, resolution will not be reattempted until the update interval of redhat-techpreview-all-repository has elapsed or updates are forced -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException






Steps to Reproduce:
1. follow steps from https://bugzilla.redhat.com/show_bug.cgi?id=1016660
Comment 1 kconner 2013-10-30 20:43:10 EDT
Shouldn't the repository be http://maven.repository.redhat.com/techpreview/ip6/6.0.0.Beta/maven-repository/?

If I use the above repository then it works for me.

Note You need to log in before you can comment on or make changes to this bug.