Bug 1016719 - Post installation server start failure - Failed to persist configuration change on windows
Post installation server start failure - Failed to persist configuration chan...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
urgent Severity urgent
: ER4
: 6.0.0
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 10:57 EDT by Pavol Srna
Modified: 2014-02-06 10:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (163.81 KB, image/png)
2013-10-08 10:57 EDT, Pavol Srna
no flags Details

  None (edit)
Description Pavol Srna 2013-10-08 10:57:25 EDT
Created attachment 809347 [details]
screenshot

Description of problem:



[Host Controller] 07:51:17,127 ERROR [org.jboss.as.controller.management-operation] (management-handler-thread - 4) JBAS014607: Failed to persist configuration change: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014675: Failed to marshal configuration
[Host Controller] 	at org.jboss.as.controller.persistence.AbstractFilePersistenceResource.<init>(AbstractFilePersistenceResource.java:50) [jboss-as-controller-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
[Host Controller] 	at org.jboss.as.controller.persistence.ConfigurationFilePersistenceResource.<init>(ConfigurationFilePersistenceResource.java:45) [jboss-as-controller-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
[Host Controller] 	at org.jboss.as.controller.persistence.BackupXmlConfigurationPersister.store(BackupXmlConfigurationPersister.java:80) [jboss-as-controller-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
[Host Controller] 	at org.jboss.as.host.controller.HostControllerConfigurationPersister.store(HostControllerConfigurationPersister.java:125)
Comment 1 Pavol Srna 2013-10-08 10:59:21 EDT
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b17)
Java HotSpot(TM) Client VM (build 23.25-b01, mixed mode, sharing)
Comment 2 Len DiMaggio 2013-10-08 11:05:12 EDT
Just to confirm - this error is seen when the server is started AFTER the installation is completed and the installer has closed/exited - yes?
Comment 3 Len DiMaggio 2013-10-08 11:08:54 EDT
What install path are you using?
Comment 4 Thomas Hauser 2013-10-08 11:34:03 EDT
Looking at the screenshot, it seems that the installer is failing to launch the server. The machine seems slow, I assume this is a VM / another timing issue at this point. We are working on it.
Comment 5 Pavol Srna 2013-10-08 11:41:39 EDT
Yes this is VM.
Comment 6 Pavol Srna 2013-10-08 11:48:39 EDT
I Saw this on a physical machine in the Brno lab a while ago. But this issues seems to be not 100% reproducible.
Comment 7 Len DiMaggio 2013-10-08 12:08:15 EDT
I am not able to get an installation to even get to this point - on Windows 7 installs I am blocked 100% of the time by this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1015423
Comment 8 Len DiMaggio 2013-10-11 11:37:08 EDT
Unable to recreate this problem on Windows7 with Oracle 1.7 and FSW6.ER4.respin3

Note You need to log in before you can comment on or make changes to this bug.