Bug 101678 - libtcl.so.0 and libtk.so.0 links are missing
libtcl.so.0 and libtk.so.0 links are missing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
:
: 104579 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-05 11:24 EDT by jmccann
Modified: 2015-01-14 18:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-05 23:40:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmccann 2003-08-05 11:24:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
RH9 is missing two library links that were present in previous versions:

/usr/lib/libtk.so.0
/usr/lib/libtcl.so.0

This means that programs that use tcl/tk that were built on a previous version
break in RH9.

Simply creating a link from /usr/lib/libtcl.so.0
 to /usr/lib/libtcl.so or /usr/lib/libtcl8.3.so solves the problem.

Version-Release number of selected component (if applicable):
tk-8.3.5-88

How reproducible:
Always

Steps to Reproduce:
1. n/a


Actual Results:  Programs break between RH8.0 and RH9.

Expected Results:  They just work.

Additional info:
Comment 1 Jens Petersen 2003-08-05 23:40:24 EDT
Yes, I am afraid this is intentional.  The so names in RHL 8.0 and earlier
were non-standard (ad-hoc).  I decided when updating tcltk for RHL 9 that
following the so naming conventions of upstream is the right thing to do.
Comment 2 jmccann 2003-08-07 11:32:49 EDT
As I'm sure you are aware this very undesireable.  Here at JHU we have a large
collection of systems that use a shared /usr/local.  As we update our systems
incrementally we have both RH8.0 and RH9 in production.  Lots of broken software...

That said, it sounds like you made the right decision to use the standard naming.

Is there some kind of meta-bug for similar backward compatibility and API/ABI
stability issues?  These are very important for many people.
Comment 3 Jens Petersen 2003-09-18 02:48:11 EDT
*** Bug 104579 has been marked as a duplicate of this bug. ***
Comment 4 Jens Petersen 2003-09-18 02:54:35 EDT
As noted in bug 104579 there is backwards compatibility however:
On RHL 8.0 and earlier there is a symlink lib{tcl,tk}8.3.so ->
lib{tcl,tk}.so.0, so programs linked against tcltk on RHL9 should run ok
on 8.0 all other things being equal.

I'm not aware of a better place to report API/ABI issues.

Note You need to log in before you can comment on or make changes to this bug.