Bug 104579 - Need for libtcl.so.0 and libtk.so.0
Summary: Need for libtcl.so.0 and libtk.so.0
Status: CLOSED DUPLICATE of bug 101678
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tcltk (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-17 15:19 UTC by Olle Liljenzin
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olle Liljenzin 2003-09-17 15:20:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
A program using tcltk and is linked on RH8 or earlier will require libtcl.so.0 
and libtk.so.0

The libraries in taroon-beta are installed with the names libtcl8.3.so and 
libtk8.3.so

The program will not run on taroon-beta since the expected libraries are not 
found.

On RH8 there are softlinks /usr/lib/libtcl8.3.so->libtcl.so.0 
and /usr/lib/libtk8.3.so->libtk.so.0, but not on taroon-beta, thus it does not 
help to link with the options '-ltk8.3 -ltcl8.3'.

We need a way to link a program so that it can run on both RH8 and Enterprise 
Linux, which is not possible now.


Version-Release number of selected component (if applicable):
tk-8.3.5-90, tcl-8.3.5-90

How reproducible:
Always

Steps to Reproduce:
1."readelf -d /usr/lib/libtcl8.3.so|grep SONAME"
2."readelf -d /usr/lib/libtk8.3.so|grep SONAME"
3.
    

Actual Results:  RH8:
libtcl.so.0
libtk.so.0

taroon-beta:
libtcl8.3.so
libtk8.3.so

Expected Results:  The output should't differ

Additional info:

Comment 1 Jens Petersen 2003-09-18 06:48:05 UTC
I suggest you either build on Taroon, in which case your executable will
be linked against /usr/lib/lib{tcl,tk}8.3.so and run on RHL 8.0, or create
/usr/lib/lib{tcl,tk}.so.0 symlinks on Taroon to run a binary built on 8.0.

Please see the duplicate bug for more details.

*** This bug has been marked as a duplicate of 101678 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:36 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.