Bug 1016801 - "Don't install the latest software updates" box is unchecked by default, can't be checked permanently
"Don't install the latest software updates" box is unchecked by default, can'...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F20BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-10-08 13:29 EDT by Andre Robatino
Modified: 2013-11-04 22:38 EST (History)
10 users (show)

See Also:
Fixed In Version: anaconda-20.25.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 22:38:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2013-10-08 13:29:35 EDT
Description of problem:
In 20 Beta TC1 and 20 Beta TC2, on the install DVDs, under the "Installation Source" spoke, the "Don't install the latest software updates" box is unchecked by default, and if you check it, exit and reenter the spoke, it's unchecked again. It seems to install without downloading updates, but I don't know what repo(s) it's looking at. (Is it just stable updates, which are currently empty?)

Version-Release number of selected component (if applicable):
anaconda 20.21-1 and 20.22-1
Comment 1 Andre Robatino 2013-10-08 20:57:47 EDT
The same thing happens with the netinst. If you check the box, exit and reenter the spoke, the box is unchecked again.
Comment 2 Andre Robatino 2013-10-10 20:07:39 EDT
Proposing as Beta Freeze Exception. Even if you manually check the box, it's unchecked again on reentering the spoke, so you can't tell what setting is actually being used.
Comment 3 Andre Robatino 2013-10-13 07:29:19 EDT
Just for reference, by default the box is supposed to be checked on the DVD and unchecked on the netinst. Also, in https://bugzilla.redhat.com/show_bug.cgi?id=1016927 Dan Mashal says that on the netinstall, checking the box has an effect, so checking it must be doing something, even though it's unchecked again if you reenter the spoke. So presumably the updates come from whatever repos are enabled by default at the time (fedora and updates-testing now, fedora and updates later).
Comment 4 Brian Lane 2013-10-14 12:55:21 EDT
Note that we currently don't have any updates.
Comment 5 Brian Lane 2013-10-14 12:59:40 EDT
Although I see we have repodata so, something is odd.
Comment 6 Adam Williamson 2013-10-16 13:10:57 EDT
IIRC, I filed a bug back in F19 timeframe to make that checkbox use the appropriate repos at the appropriate times, so it ought to be doing the right thing (aside from *this* bug).
Comment 7 Adam Williamson 2013-10-16 13:30:24 EDT
Discussed at 2013-10-16 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-16/f20beta-blocker-review-4.2013-10-16-16.02.log.txt . Accepted as a freeze exception issue: this is a fairly significant control and should work for Beta if possible, but if the fix is too intrusive, we'd better not take it.
Comment 8 Fedora Update System 2013-10-25 21:10:22 EDT
anaconda-20.25.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.25.4-1.fc20
Comment 9 Andre Robatino 2013-10-26 12:55:34 EDT
This particular problem appears fixed in 20 Beta TC6 (anaconda-20.25.4-1). The "Don't install the latest software updates" box is unchecked by default on the netinst and checked by default on the DVD, and if you check/uncheck it and exit and reenter the spoke, it stays in the same state. I can't tell if it's actually downloading updates, but at least it looks normal.

There is a different issue, though. On the DVD, if you enter the "Installation Source" spoke and change the installation source to "On the network", then exit and reenter the spoke, it changes back to "Auto-detected installation media". Should I file a separate bug for that?
Comment 10 Adam Williamson 2013-10-26 13:20:14 EDT
Yes, I think you should. Thanks!
Comment 11 Fedora Update System 2013-10-26 14:48:59 EDT
Package anaconda-20.25.4-1.fc20, pykickstart-1.99.44-1.fc20, python-blivet-0.23.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.4-1.fc20 pykickstart-1.99.44-1.fc20 python-blivet-0.23.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20033/pykickstart-1.99.44-1.fc20,python-blivet-0.23.2-1.fc20,anaconda-20.25.4-1.fc20
then log in and leave karma (feedback).
Comment 12 Andre Robatino 2013-10-27 08:05:46 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1023725 (on any install image, when entering "Installation Source" spoke, selection is always the default, even if previously changed)

I'm not sure whether to propose this as a Freeze Exception, since it's an old bug, and it may be more obvious during the install what the actual installation source is, as opposed to whether updates are being downloaded.
Comment 13 satellitgo 2013-10-27 09:10:01 EDT
Appears fixed in TC6 f20 Beta TC6 x86_64 DVD
Checkbox is checked by default and stays checked on revisit to spoke
Comment 14 satellitgo 2013-10-27 15:46:39 EDT
Causes "error checking software selection" in software spoke in F20 DVD x86_64 with box checked by default. Sugar installs fine if unchecked ?  due to unsatisfied known sugar application dependency  on DVD that is fixed on updates ?
Comment 15 satellitgo 2013-10-27 15:47:34 EDT
This is f20 TC6 DVD
Comment 16 Andre Robatino 2013-10-27 15:50:17 EDT
That's probably https://bugzilla.redhat.com/show_bug.cgi?id=1023657 (repoclosure failure on 20 Beta TC6 DVDs (sugar-write)) and not related to this bug.
Comment 17 Fedora Update System 2013-11-04 22:38:30 EST
anaconda-20.25.4-1.fc20, pykickstart-1.99.44-1.fc20, python-blivet-0.23.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.