Bug 10169 - updatedb dumps core
updatedb dumps core
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: slocate (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-14 12:41 EST by R P Herrold
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-20 11:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2000-03-14 12:41:46 EST
Bug 9445 had this issue as well.

... I think it is NOT fixed ... updatedb has never worked on 6.1 for me.


[root@pokey bin]# updatedb ; cat /etc/redhat-release ; rpm -q slocate
<snip>
socket(PF_UNIX, SOCK_STREAM, 0)         = 3
connect(3, {sun_family=AF_UNIX, sun_path="/var/run/.nscd_socket"}, 110) =
-1 ECONNREFUSED (Connection refused)
close(3)                                = 0
open("/etc/nsswitch.conf", O_RDONLY)    = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=1744, ...}) = 0
mmap(0, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40013000
read(3, "#\n# /etc/nsswitch.conf\n#\n# An ex"..., 4096) = 1744
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++
Red Hat Linux release 6.1 (Cartman)
slocate-2.1-2
[root@pokey bin]# ls -al /etc/nsswitch.conf
-rw-r--r--   1 root     root         1744 Sep 20 05:13 /etc/nsswitch.conf
[root@pokey bin]#
Comment 1 Bill Nottingham 2000-03-14 12:49:59 EST
What's your nsswitch.conf file look like; also, can you get a backtrace
of a debugging version?
Comment 2 R P Herrold 2000-03-14 13:14:59 EST
... looks pretty generic to me ...

[root@pokey bin]# cat /etc/nsswitch.conf
#
# /etc/nsswitch.conf
#
# An example Name Service Switch config file. This file should be
# sorted with the most-used services at the beginning.
#
# The entry '[NOTFOUND=return]' means that the search for an
# entry should stop if the search in the previous entry turned
# up nothing. Note that if the search failed due to some other reason
# (like no NIS server responding) then the search continues with the
# next entry.
#
# Legal entries are:
#
#       nisplus or nis+         Use NIS+ (NIS version 3)
#       nis or yp               Use NIS (NIS version 2), also called YP
#       dns                     Use DNS (Domain Name Service)
#       files                   Use the local files
#       db                      Use the local database (.db) files
#       compat                  Use NIS on compat mode
#       hesiod                  Use Hesiod for user lookups
#       [NOTFOUND=return]       Stop searching if not found so far
#

# To use db, put the "db" in front of "files" for entries you want to be
# looked up first in the databases
#
# Example:
#passwd:    db files nisplus nis
#shadow:    db files nisplus nis
#group:     db files nisplus nis

passwd:     files nisplus nis
shadow:     files nisplus nis
group:      files nisplus nis

#hosts:     db files nisplus nis dns
hosts:      files nisplus nis dns

# Example - obey only what nisplus tells us...
#services:   nisplus [NOTFOUND=return] files
#networks:   nisplus [NOTFOUND=return] files
#protocols:  nisplus [NOTFOUND=return] files
#rpc:        nisplus [NOTFOUND=return] files
#ethers:     nisplus [NOTFOUND=return] files
#netmasks:   nisplus [NOTFOUND=return] files

bootparams: nisplus [NOTFOUND=return] files

ethers:     files
netmasks:   files
networks:   files
protocols:  files
rpc:        files
services:   files

netgroup:   nisplus

publickey:  nisplus

automount:  files nisplus
aliases:    files nisplus

----------------------------------------------------
Comment 3 Bill Nottingham 2000-03-20 11:05:59 EST
fixed as of the latest slocate build (2.1-3)
Comment 4 R P Herrold 2000-10-11 14:45:19 EDT
... the issue turned out to be a combination of the LOCALE env. variable being
set, and slocate not creating a new locate.db cleanyl ...

Note You need to log in before you can comment on or make changes to this bug.