Bug 1016938 - glusterfs-api-devel is missing deps
glusterfs-api-devel is missing deps
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glusterfs (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Niels de Vos
Fedora Extras Quality Assurance
:
Depends On: 1017094
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 21:25 EDT by Eric Blake
Modified: 2013-12-14 22:38 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.1-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1017094 1065750 (view as bug list)
Environment:
Last Closed: 2013-12-13 22:05:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Blake 2013-10-08 21:25:32 EDT
Description of problem:
I installed glusterfs-api-devel, added a pkg-config line to my configure.ac, then tried to compile.

Version-Release number of selected component (if applicable):
glusterfs-api-devel-3.4.0-8.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. yum install glusterfs-api-devel
2. echo 'int main(){}' > bar.c
3. $ gcc -o bar bar.c $(pkg-config --libs glusterfs-api)


Actual results:
3.
/usr/bin/ld: cannot find -lglusterfs
/usr/bin/ld: cannot find -lgfrpc
/usr/bin/ld: cannot find -lgfxdr
collect2: error: ld returned 1 exit status


Expected results:
Pulling in the devel library should also drag in any other packages necessary so that the pkg-config setup works.

Additional info:
Comment 1 Eric Blake 2013-10-08 23:26:36 EDT
Looks like 'yum install glusterfs-devel' was enough to fix the link failures, meaning glusterfs-api-devel needs a Requires: glusterfs-devel in its spec file.
Comment 2 Niels de Vos 2013-10-09 06:17:22 EDT
Thanks for the report Eric! This will be fixed with the next update.
Comment 3 Niels de Vos 2013-10-09 09:45:31 EDT
Moving back to a Fedora packaging bug, upstream has been cloned to 1017094 already
Comment 4 Fedora Update System 2013-10-27 10:32:57 EDT
glusterfs-3.4.1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/glusterfs-3.4.1-3.fc18
Comment 5 Fedora Update System 2013-10-27 10:33:19 EDT
glusterfs-3.4.1-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/glusterfs-3.4.1-3.fc19
Comment 6 Fedora Update System 2013-10-27 10:33:38 EDT
glusterfs-3.4.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/glusterfs-3.4.1-3.fc20
Comment 7 Fedora Update System 2013-10-27 14:11:54 EDT
Package glusterfs-3.4.1-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glusterfs-3.4.1-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20091/glusterfs-3.4.1-3.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-12-13 22:05:34 EST
glusterfs-3.4.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-12-14 22:34:07 EST
glusterfs-3.4.1-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-12-14 22:38:36 EST
glusterfs-3.4.1-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.