Bug 1017094 - glusterfs-api-devel is missing deps
glusterfs-api-devel is missing deps
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Niels de Vos
:
Depends On:
Blocks: 1016938
  Show dependency treegraph
 
Reported: 2013-10-09 05:12 EDT by Niels de Vos
Modified: 2014-04-17 07:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1016938
Environment:
Last Closed: 2014-04-17 07:49:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2013-10-09 05:12:18 EDT
Upstream Gluster project version of Bug #1016938

+++ This bug was initially created as a clone of Bug #1016938 +++

Description of problem:
I installed glusterfs-api-devel, added a pkg-config line to my configure.ac, then tried to compile.

Version-Release number of selected component (if applicable):
glusterfs-api-devel-3.4.0-8.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. yum install glusterfs-api-devel
2. echo 'int main(){}' > bar.c
3. $ gcc -o bar bar.c $(pkg-config --libs glusterfs-api)


Actual results:
3.
/usr/bin/ld: cannot find -lglusterfs
/usr/bin/ld: cannot find -lgfrpc
/usr/bin/ld: cannot find -lgfxdr
collect2: error: ld returned 1 exit status


Expected results:
Pulling in the devel library should also drag in any other packages necessary so that the pkg-config setup works.

Additional info:

--- Additional comment from Eric Blake on 2013-10-09 05:26:36 CEST ---

Looks like 'yum install glusterfs-devel' was enough to fix the link failures, meaning glusterfs-api-devel needs a Requires: glusterfs-devel in its spec file.
Comment 1 Anand Avati 2013-10-09 05:23:24 EDT
REVIEW: http://review.gluster.org/6056 (rpm: glusterfs-api-devel requires glusterfs-devel) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 2 Anand Avati 2013-10-09 23:25:20 EDT
COMMIT: http://review.gluster.org/6056 committed in master by Anand Avati (avati@redhat.com) 
------
commit c436b89a7111bbaaed9f034799986ea7c760ce55
Author: Niels de Vos <ndevos@redhat.com>
Date:   Wed Oct 9 11:13:11 2013 +0200

    rpm: glusterfs-api-devel requires glusterfs-devel
    
    When installing the glusterfs-api-devel package in order to build
    software that uses libgfapi, there are unmet dependencies. Installing
    glusterfs-devel additionally solved these link errors:
    
      $ echo 'int main(){}' > bar.c
      $ gcc -o bar bar.c $(pkg-config --libs glusterfs-api)
      /usr/bin/ld: cannot find -lglusterfs
      /usr/bin/ld: cannot find -lgfrpc
      /usr/bin/ld: cannot find -lgfxdr
      collect2: error: ld returned 1 exit status
    
    Change-Id: I12e922aa6609809c03ec2c9a0d8a47c5df91d0a1
    BUG: 1017094
    Reported-by: Eric Blake <eblake@redhat.com>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/6056
    Reviewed-by: Bala FA <barumuga@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Niels de Vos 2014-04-17 07:49:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.