Bug 1017144 - Packstack does not provide installation/configuration of the 'ml2' core plugin
Packstack does not provide installation/configuration of the 'ml2' core plugin
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
urgent Severity high
: z3
: 4.0
Assigned To: Martin Magr
Nir Magnezi
: TestBlocker, ZStream
Depends On: 1017280 1066519 1068936 1068962
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 06:28 EDT by Rami Vaknin
Modified: 2018-02-08 05:07 EST (History)
12 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.27.dev989.el6ost
Doc Type: Enhancement
Doc Text:
Previously, it was not possible to use the ML2 L2 plugin with OpenStack Networking. This has been fixed so that the CONFIG_NEUTRON_L2_PLUGIN parameter accepts the value "ml2", and CONFIG_NEUTRON_ML2_* parameters have been introduced to enable OpenStack Networking to work with the ML2 plugin.
Story Points: ---
Clone Of:
: 1017280 (view as bug list)
Environment:
Last Closed: 2014-03-25 15:23:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 48289 None None None Never
OpenStack gerrit 65954 None None None Never
OpenStack gerrit 70086 None None None Never

  None (edit)
Description Rami Vaknin 2013-10-09 06:28:15 EDT
Version
=======
rhos 4.0 on rhel 6.5, 

Description
===========
Currently, it's impossible to auto-configure neutron to use the "ml2" plugin.

Packstack should allow that, which mean it should provide an option to choose the core plugin which would configure the core_plugin to be "neutron.plugins.ml2.plugin.Ml2Plugin" after installation of openstack-neutron-ml2.noarch.
Comment 3 Terry Wilson 2013-10-21 15:17:50 EDT
There is an upstream puppet-neutron patch for adding ML2 support (which packstack work will depend on) located here: https://review.openstack.org/#/c/48289/ that is still a work in progress.
Comment 8 Alvaro Lopez Ortega 2014-01-14 12:33:09 EST
Currently in Gerrit for Review. Unfortunately it won't make it to A1 though.
Comment 12 Ofer Blaut 2014-02-23 11:41:58 EST
The main feature can't be tested and failed QA
Comment 13 Martin Magr 2014-02-24 04:20:42 EST
Please provide detailed info what is not working and should be fixed. Comment 12 is telling us completely nothing. From our point of view Neutron installation with ML2 is installed successfully without any error in logs, so I guess this might me configuration problem. And with that we have to know exactly what is wrong.
Comment 14 Martin Magr 2014-02-24 04:40:21 EST
I just noticed the blocking bugs, ignore my last comment :).
Comment 15 Nir Magnezi 2014-03-03 04:06:58 EST
Moving back to assigned due to:
https://bugzilla.redhat.com/show_bug.cgi?id=1068962#c7
https://bugzilla.redhat.com/show_bug.cgi?id=1066519#c5

Please specify what is fixed and how it should be tested.
Comment 18 Martin Magr 2014-03-07 06:13:52 EST
Nir, I've tested build in fixed_in as all-in-one installation and controller+compute+network multi-host installation and installation passed without problem. How to properly test ML2 functionality should be answered by somebody from Neutron.
Comment 19 Nir Magnezi 2014-03-12 16:55:31 EDT
Verified NVR: openstack-packstack-2013.2.1-0.28.dev989.el6ost

Both:
Bug #1066519 Comment #11
Bug #1068962 Comment #12

Verifies this bug.
Comment 21 errata-xmlrpc 2014-03-25 15:23:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0334.html

Note You need to log in before you can comment on or make changes to this bug.