Bug 1017280 - OpenStack puppet modules do not provide installation/configuration of the 'ml2' core plugin
OpenStack puppet modules do not provide installation/configuration of the 'ml...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
urgent Severity high
: rc
: 4.0
Assigned To: Martin Magr
Martin Magr
: OtherQA, TestBlocker, Triaged
Depends On:
Blocks: 1017144 1017281
  Show dependency treegraph
 
Reported: 2013-10-09 10:46 EDT by Perry Myers
Modified: 2016-04-26 13:05 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.14.dev919.el6ost
Doc Type: Known Issue
Doc Text:
Currently, puppet does not support deployment of the ML2 Neutron plugin. The ML2 plugin can be used in manual configurations, or by deploying initially with the Open vSwitch plugin using PackStack, and then converting the installation to use ML2. This last method is described on the RDO pages at http://openstack.redhat.com/Modular_Layer_2_%28ML2%29_Plugin
Story Points: ---
Clone Of: 1017144
: 1017281 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:27:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 48289 None None None Never

  None (edit)
Description Perry Myers 2013-10-09 10:46:38 EDT
+++ This bug was initially created as a clone of Bug #1017144 +++

Version
=======
rhos 4.0 on rhel 6.5, 

Description
===========
Currently, it's impossible to auto-configure neutron to use the "ml2" plugin.

Packstack should allow that, which mean it should provide an option to choose the core plugin which would configure the core_plugin to be "neutron.plugins.ml2.plugin.Ml2Plugin" after installation of openstack-neutron-ml2.noarch.

--- Additional comment from Perry Myers on 2013-10-09 10:44:08 EDT ---

I think this needs to be done by a combination of rkukura (since he did the majority of the work on ml2 plugin and knows it best) along with the Packstack and Puppet folks.

This is actually not Packstack specific.  We'll need to clone this to the puppet modules component as well and Foreman too.
Comment 1 Alvaro Lopez Ortega 2013-12-03 12:43:48 EST
Martin has been already working on this AFAIK.
Comment 2 Martin Magr 2013-12-04 07:22:19 EST
Emilien's patch has been merged upstream.
Comment 3 Scott Lewis 2013-12-09 10:33:42 EST
Adding OtherQA for bugs in MODIFIED
Comment 6 Bob Kukura 2013-12-10 11:22:09 EST
Please do not state that the ML2 plugin does not work without referencing a specific BZ. This issue in this BZ regards packstack, not ML2 iteself.

I think the release note should be something like:

Packstack does not support deployment of the ML2 neutron plugin as of the RHOS 4.0 release. The ML2 plugin can be used in manual configurations, or by deploying initially with the openvswitch plugin using packstack and then converting the installation to use ML2 as described at http://openstack.redhat.com/Modular_Layer_2_%28ML2%29_Plugin (for RDO).


Of course, it might be better to include the contents of the RDO article in the release not, or in a RHOS-specific KB article.
Comment 7 Rami Vaknin 2013-12-11 10:38:14 EST
This bug is ON_QA with a specified "fixed_in_version" and comments #1 + #2 state that a work has been done on this bug, however comment #6 and the doc_text state that there is no ml2 installation by packstack.

Could you please tell what should be done here?
Comment 8 Martin Magr 2013-12-12 11:44:58 EST
[para@elysium packstack]$ find  packstack/puppet/modules/neutron/manifests/ -iname *ml2*
packstack/puppet/modules/neutron/manifests/plugins/ml2
packstack/puppet/modules/neutron/manifests/plugins/ml2.pp

[para@elysium packstack]$ cat packstack/puppet/modules/neutron/manifests/plugins/ml2.pp
#
# Copyright (C) 2013 eNovance SAS <licensing@enovance.com>
#
# Author: Emilien Macchi <emilien.macchi@enovance.com>
#
# Licensed under the Apache License, Version 2.0 (the "License"); you may
# not use this file except in compliance with the License. You may obtain
# a copy of the License at
#
#      http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
# License for the specific language governing permissions and limitations
# under the License.

# Configure the neutron server to use the ML2 plugin.
# This configures the plugin for the API server, but does nothing
# about configuring the agents that must also run and share a config
# file with the OVS plugin if both are on the same machine.
#
# === Parameters
#
# [*type_drivers*]
#   (optional) List of network type driver entrypoints to be loaded
#   from the neutron.ml2.type_drivers namespace.
#   Could be an array that can have these elements:
#   local, flat, vlan, gre, vxlan
#   Defaults to ['local', 'flat', 'vlan', 'gre', 'vxlan'].
#
# [*tenant_network_types*]
#   (optional) Ordered list of network_types to allocate as tenant networks.
#   The value 'local' is only useful for single-box testing
#   but provides no connectivity between hosts.
#   Should be an array that can have these elements:
#   local, flat, vlan, gre, vxlan
#   Defaults to ['local', 'flat', 'vlan', 'gre', 'vxlan'].
#
# [*mechanism_drivers*]
#   (optional) An ordered list of networking mechanism driver
#   entrypoints to be loaded from the neutron.ml2.mechanism_drivers namespace.
#   Should be an array that can have these elements:
#   logger, test, linuxbridge, openvswitch, hyperv, ncs, arista, cisco_nexus,
#   l2population.
#   Default to ['openvswitch', 'linuxbridge'].
#
# [*flat_networks*]
#   (optional) List of physical_network names with which flat networks
#   can be created. Use * to allow flat networks with arbitrary
#   physical_network names.
#   Should be an array.
#   Default to *.
#
# [*network_vlan_ranges*]
#   (optional) List of <physical_network>:<vlan_min>:<vlan_max> or
#   <physical_network> specifying physical_network names
#   usable for VLAN provider and tenant networks, as
#   well as ranges of VLAN tags on each available for
#   allocation to tenant networks.
#   Should be an array with vlan_min = 1 & vlan_max = 4094 (IEEE 802.1Q)
#   Default to empty.
#
# [*tunnel_id_ranges*]
#   (optional) Comma-separated list of <tun_min>:<tun_max> tuples
#   enumerating ranges of GRE tunnel IDs that are
#   available for tenant network allocation
#   Should be an array with tun_max +1 - tun_min > 1000000
#   Default to empty.
#
# [*vxlan_group*]
#   (optional) Multicast group for VXLAN.
#   Multicast group for VXLAN. If unset, disables VXLAN enable sending allocate
#   broadcast traffic to this multicast group. When left unconfigured, will
#   disable multicast VXLAN mode
#   Should be an Multicast IP (v4 or v6) address.
#   Default to 'None'.
#
# [*vni_ranges*]
#   (optional) Comma-separated list of <vni_min>:<vni_max> tuples
#   enumerating ranges of VXLAN VNI IDs that are
#   available for tenant network allocation.
#   Min value is 0 and Max value is 16777215.
#   Default to empty.
#

class neutron::plugins::ml2 (
  $type_drivers          = ['local', 'flat', 'vlan', 'gre', 'vxlan'],
  $tenant_network_types  = ['local', 'flat', 'vlan', 'gre', 'vxlan'],
  $mechanism_drivers     = ['openvswitch', 'linuxbridge'],
  $flat_networks         = ['*'],
  $network_vlan_ranges   = ['10:50'],
  $tunnel_id_ranges      = ['20:100'],
  $vxlan_group           = '224.0.0.1',
  $vni_ranges            = ['10:100']
) {
Comment 11 errata-xmlrpc 2013-12-19 19:27:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.