Bug 101716 - (ICH5) Installer does not find intel 875p SATA controller
(ICH5) Installer does not find intel 875p SATA controller
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-05 18:58 EDT by brian atkisson
Modified: 2013-07-02 22:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-25 20:26:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "lspci -vvvn" on my Intel S875WP1-E based computer (7.55 KB, text/plain)
2003-08-12 12:21 EDT, Paul Bender
no flags Details

  None (edit)
Description brian atkisson 2003-08-05 18:58:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030718

Description of problem:
Installer does not find a SATA harddrive connected to an Intel 875P motherboard.

Version-Release number of selected component (if applicable):
redhat 10 beta 1

How reproducible:
Always

Steps to Reproduce:
1.boot redhat 10 beta 1 installer
2.
3.
    

Actual Results:  could not find harddrive

Expected Results:  the harddrive to be found

Additional info:
Comment 1 Jeremy Katz 2003-08-05 19:16:58 EDT
Driver isn't in the kernel
Comment 2 Jeff Garzik 2003-08-11 11:15:58 EDT
lspci?

ata_piix driver should be in taroon-beta1, actually.  rpm -qlp shows it.
Comment 3 Paul Bender 2003-08-12 11:15:27 EDT
Are there plans to put the driver in the kernel before Severn is released? It is
my understanding that support for it is in Alan Cox's 2.4.21-ac4 patch. Since I
have an Intel S875WP1-E motherboard, it would be great for me if it were supported.
Comment 4 Jeff Garzik 2003-08-12 11:33:48 EDT
Ah, Severn!  Yes, we intend to support i875 SATA in severn too.  So, lack of
support is definitely a bug we wish to fix...

Can you post 'lspci -vvvn' as root?
Comment 5 Paul Bender 2003-08-12 12:21:22 EDT
Created attachment 93605 [details]
Output of "lspci -vvvn" on my Intel S875WP1-E based computer

As requested, I have attached the output of "lspci -vvvn".

In case it is helpful, I thought I would provide some more information on my
configuration. Since the kernel does not support the SATA on i875p, I have
configured the BIOS to use legacy ATA mode. I am using two Seagate ST3160023AS
drives configured to use software RAID Level 1. I have one additional Intel
Pro/100 Ethernet card plugged into the last PCI slot.
Comment 6 Paul Bender 2003-08-27 20:23:19 EDT
I downloaded, configured, compiled and installed the vanilla 2.4.22 kernel from
kernel.org. It appears that the 2.4.22 kernel recognizes my SATA drives.
Comment 7 Paul Bender 2003-09-04 12:18:31 EDT
I downloaded and installed the 2.4.22-20.1.2024.2.36.nptl kernel RPMs for
rawhide. However, unlike the vanilla 2.4.22 kernel that I compiled myself, the
kernel RPMs do not recognize the SATA hard drives.

In addition, the kernel RPMs do not recognize the onboard sensors. I assume that
this means that the 2.8.0 patches for lm_sensors and i2c have not been applied.
I patched my vanilla 2.4.22 kernel and the sensors on the motherboard are
recognized.

BTW, I have changed my configuration. I have installed Severn on a PATA drive
that I connected to the secondary IDE controller. In addition, I have taken the
SATA out of legacy mode. Under the vanilla 2.4.22 kernel, the PATA drive shows
up as /dev/hdc and the SATA drives show up as /dev/hde and /dev/hdg.
Comment 8 Bill Nottingham 2003-10-21 16:21:49 EDT
Does this work in test3 or later?
Comment 9 Paul Bender 2003-10-21 22:35:15 EDT
I have not installed test3, but I have been keeping the machine sync-ed with 
Raw Hide. Therefore, I believe that I am running the latest kernel (2.4.22-
1.2097). It does not work with that kernel. If it would help, I can send my 
config file for my 2.4.22 kernel that works.
Comment 10 Edward Stangler 2003-10-25 06:28:55 EDT
Not sure if this helps, but kernel-2.4.22-1.2088.nptl (Severn test 3) finds my
120GB Seagate SATA drive on a Dell Optiplex GX270 (82801EB ICH5) just fine.

Regarding the comment about sensors:  the i2c-i801 driver (1.6.5) fails to load
on ICH5, so no lm_sensors.  Any chance we could get i2c-i801 upgraded to 2.8.0
(rev. 1.3.3), which added ICH5 support?  Code changes seem straightforward; 
acts like ICH4.
Comment 11 brian atkisson 2003-10-25 20:26:57 EDT
seems to work fine with beta 2 & 3.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.