Bug 101718 - Random panics on Dell laptop
Random panics on Dell laptop
Status: CLOSED NOTABUG
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-05 19:53 EDT by Need Real Name
Modified: 2015-01-04 17:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-13 12:10:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-08-05 19:53:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
While trying to track down random X crashes, I found that my machine had
paniced.  Occasionally I've had complete system locks as well, which probably
would have shown a panic if I hadn't been in X.

Here is the panic I was able to capture:

Aug  5 15:36:56 localhost kernel: Unable to handle kernel paging request at
virtual address 6bcd031f
Aug  5 15:36:56 localhost kernel:  printing eip:
Aug  5 15:36:56 localhost kernel: c0132a93
Aug  5 15:36:56 localhost kernel: *pde = 00000000
Aug  5 15:36:56 localhost kernel: Oops: 0000
Aug  5 15:36:56 localhost kernel: maestro soundcore parport_pc lp parport sd_mod
scsi_mod ide-cd cdrom autofs orinoco_cs orinoco hermes ds yenta_socket
pcmcia_core floppy microcode keybdev mou
Aug  5 15:36:56 localhost kernel: CPU:    0
Aug  5 15:36:56 localhost kernel: EIP:    0060:[<c0132a93>]    Not tainted
Aug  5 15:36:56 localhost kernel: EFLAGS: 00013202
Aug  5 15:36:56 localhost kernel:
Aug  5 15:36:56 localhost kernel: EIP is at find_vma [kernel] 0x33
(2.4.21-20.1.2024.2.1.nptl)
Aug  5 15:36:56 localhost kernel: eax: 6bcd0317   ebx: 0000005d   ecx: cd0326a9
  edx: 6bcd032f
Aug  5 15:36:56 localhost kernel: esi: ce5e9744   edi: c0118140   ebp: 0000005d
  esp: ccfe3f04
Aug  5 15:36:56 localhost gdm(pam_unix)[2085]: session closed for user gboyce
Aug  5 15:36:56 localhost kernel: ds: 0068   es: 0068   ss: 0068
Aug  5 15:36:57 localhost kernel: Process X (pid: 2086, stackpage=ccfe3000)
Aug  5 15:36:57 localhost gdm[2085]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0
Aug  5 15:36:57 localhost kernel: Stack: ce5e9744 ce5e9768 c01181c4 ce5e9744
0000005d ce3b79c8 ce3b79ec ccfe2000
Aug  5 15:36:57 localhost kernel:        c013b885 cffda100 ce3b7000 00030001
00000041 002ab250 ce3b79cc 00003286
Aug  5 15:36:57 localhost kernel:        00000000 00003286 cffda100 ce3b79cc
00003286 ccfe2000 c01babc5 03155fd6
Aug  5 15:36:57 localhost kernel: Call Trace:   [<c01181c4>] do_page_fault
[kernel] 0x84 (0xccfe3f0c)
Aug  5 15:36:58 localhost kernel: [<c013b885>] kmem_cache_free_one [kernel] 0xf5
(0xccfe3f24)
Aug  5 15:36:58 localhost kernel: [<c01babc5>] read_aux [kernel] 0xf5 (0xccfe3f5c)
Aug  5 15:36:58 localhost kernel: [<c0145164>] sys_read [kernel] 0xf4 (0xccfe3f94)
Aug  5 15:36:58 localhost kernel: [<c0118140>] do_page_fault [kernel] 0x0
(0xccfe3fb0)
Aug  5 15:36:58 localhost kernel: [<c0109ab0>] error_code [kernel] 0x34 (0xccfe3fb8)
Aug  5 15:36:58 localhost kernel:
Aug  5 15:36:58 localhost kernel:
Aug  5 15:36:58 localhost kernel: Code: 39 58 08 76 1a 39 58 04 89 c1 76 07 8b
52 0c 85 d2 75 ea 85


Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Sometimes

Steps to Reproduce:
1.Run many applications (evolution/mozilla/others)
2.Eventually X crashes.
3.Panic is found in dmesg
    

Additional info:
Comment 1 Need Real Name 2003-08-13 10:20:35 EDT
I've since started seeing similiar panics and X crashes (sig11) on Redhat 9 as
well.  After an extended run of memtest86, I found a single memory problem with
a single bit.

Unless other people are reporting similiar problems, I'm guessing my system
issues were caused by bad memory rather than a software bug.

Note You need to log in before you can comment on or make changes to this bug.