Bug 1017182 - Edit Storage Domain dialog hangs when domain connected to “None” Data Center
Edit Storage Domain dialog hangs when domain connected to “None” Data Center
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Daniel Erez
Aharon Canan
storage
: Regression
: 1023951 (view as bug list)
Depends On:
Blocks: 3.3snap1
  Show dependency treegraph
 
Reported: 2013-10-09 07:47 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 15:07 EST (History)
9 users (show)

See Also:
Fixed In Version: is20.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:12:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: Triaged+


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm (2.24 MB, application/x-gzip)
2013-10-09 07:47 EDT, vvyazmin@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20326 None None None Never
oVirt gerrit 20389 None None None Never

  None (edit)
Description vvyazmin@redhat.com 2013-10-09 07:47:26 EDT
Created attachment 809863 [details]
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm

Description of problem:
Failed edit Storage Domain connected to “None” Data Center

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS17.1 environment:

Host OS: RHEL 6.5

RHEVM:  rhevm-3.3.0-0.24.master.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.15-1.el6ev.noarch
VDSM:  vdsm-4.12.0-170.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-27.el6.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.408.el6.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Log In to RHEVM via Webadmin
2. Create Storage Domain (SD) connected to “None” Data Center
3. Edit SD

Actual results:
Failed edit SD, “Edit Domain” window stuck, see attached print-screen

Expected results:
Succeed edit SD

Impact on user:
Failed edit SD connected to “None” Data Center

Workaround:
none

Additional info:

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 2 Ayal Baron 2013-10-13 04:51:18 EDT
Vlad, why is this a regression? when could you edit a detached domain?
Comment 3 Aharon Canan 2013-10-16 05:19:46 EDT
in 3.2.4 the popup window works but fields are grayed out.
Can't edit.
moving regression.
Comment 4 Ayal Baron 2013-10-16 05:52:06 EDT
(In reply to Aharon Canan from comment #3)
> in 3.2.4 the popup window works but fields are grayed out.
> Can't edit.
> moving regression.

This actually means this is a regression.
The behaviour should be that you're allowed to view the domain properties but not edit it.
Dialog should not hang (but we should still present everything as grayed out)
Comment 5 Daniel Erez 2013-10-16 12:10:39 EDT
Hi Vladimir,
I couldn't reproduce the described issue on an iSCSI storage domain.
Can you please check whether the problem is isolated to a domain in FC environment or is it caused by a prolonged getDeviceList query?
Comment 6 vvyazmin@redhat.com 2013-10-20 06:12:08 EDT
Daniel, 

This problem reproduced with iSCSI Storage Domain in RHEVM 3.3 - IS18 environment:

Host OS: RHEL 6.5

RHEVM:  rhevm-3.3.0-0.25.beta1.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.15-1.el6ev.noarch
VDSM:  vdsm-4.13.0-0.2.beta1.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-27.el6.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.412.el6.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64

I wait 7 min, and nothing happens. No getDeviceList command is sends.
Comment 7 Maor 2013-10-29 08:36:23 EDT
*** Bug 1023951 has been marked as a duplicate of this bug. ***
Comment 10 Aharon Canan 2013-11-14 10:59:41 EST
following comment #4

verified using is23
Comment 11 Itamar Heim 2014-01-21 17:12:24 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.