Bug 1017217 - Multiple devices of same type can share "resources"
Multiple devices of same type can share "resources"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
: 1010422 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 08:58 EDT by Tomas Jamrisko
Modified: 2013-10-10 10:45 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 10:45:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2013-10-09 08:58:04 EDT
Description of problem:
Using the same device multiple times can result in them sharing some "resources", such as I/O port, interrupt or DMA channel. Which can result in them not behaving properly. 

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.410.el6.x86_64
seabios-0.6.1.2-28.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start a windows VM with 4 qxl devices: 
"-vga qxl -device qxl -device qxl -device qxl"
2. Look into Device Manager and Display adapters

Actual results:
One of those 4 adapters will have a yellow triangle with exclamation mark

Expected results:
it should work properly.

Additional info:
The error causing the warning is 'Code 12': This device cannot find enough free resources that it can use. 

http://technet.microsoft.com/en-us/library/cc732199%28v=ws.10%29.aspx
Comment 1 Tomas Jamrisko 2013-10-09 09:00:40 EDT
Adding regression as this previously worked properly. At least on qemu-kvm-rhev-0.12.1.2-2.355.el6_4.3.x86_64
Comment 4 Tomas Jamrisko 2013-10-09 11:57:51 EDT
*** Bug 1010422 has been marked as a duplicate of this bug. ***
Comment 5 Gerd Hoffmann 2013-10-10 08:26:02 EDT
Reproduces.  I see it with both 410 and 355 builds, thus no regression.

Most likely your guests are configured in different ways.  With four qxl devices you have to set the vram size to 32mb (instead of using the default of 64mb), otherwise the qxl pci bars do not fit into the pci i/o hole.  Please double-check.
Comment 6 Tomas Jamrisko 2013-10-10 10:45:25 EDT
Yes, you are right. For some reason the configuration between RHEV3.2 and RHEV3.3 got changed from 32 to 64. And now in the latest build changed it back to 32 again... Closing as NOTABUG, as this definitely wasn't an issue in qemu-kvm after all... (didn't know about the limit)

Note You need to log in before you can comment on or make changes to this bug.