Bug 1017348 - RFE: Global Proxy support for puppet syncing
RFE: Global Proxy support for puppet syncing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: FutureFeature, Triaged
Depends On: 976435 1021662
Blocks: 950743
  Show dependency treegraph
 
Reported: 2013-10-09 13:10 EDT by Eric Helms
Modified: 2014-04-24 13:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 976435
Environment:
Last Closed: 2014-04-24 13:09:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Helms 2013-10-09 13:10:05 EDT
+++ This bug was initially created as a clone of Bug #976435 +++

Description of problem:

When syncing puppet content, katello needs a global proxy configuration similar to yum syncing.

--- Additional comment from Michael Hrivnak on 2013-06-21 11:16:21 EDT ---

I think we'll accomplish this by using nectar for puppet syncs.

--- Additional comment from Randy Barlow on 2013-09-05 15:37:37 EDT ---

I believe that Jason has submitted a pull request to use Nectar for Puppet syncs, and so given Mike's comment this may be ready to be marked POST?

--- Additional comment from Michael Hrivnak on 2013-09-11 14:37:08 EDT ---

We just need to make sure that the puppet importer has a config file somewhere similar to the yum importer. As long as it exists and we can verify that nectar config values in that file are used by the importer, this RFE should be done.

--- Additional comment from Barnaby Court on 2013-09-26 08:45:18 EDT ---

Pull Requests: 
https://github.com/pulp/pulp/pull/634
https://github.com/pulp/pulp_rpm/pull/339
https://github.com/pulp/pulp_puppet/pull/75

--- Additional comment from Jeff Ortel on 2013-09-26 16:54:15 EDT ---

build: 2.3.0-0.16.alpha

--- Additional comment from Preethi Thomas on 2013-10-07 09:26:50 EDT ---

verified
[root@pulp-v2-server ~]# rpm -qa pulp-server
pulp-server-2.3.0-0.17.beta.el6.noarch
[root@pulp-v2-server ~]# 


[root@pulp-v2-server ~]# pulp-admin puppet repo create --repo-id puppet-repo --feed http://forge.puppetlabs.com --queries stdlib,mysql --proxy-host http://pulp-proxy.usersys.redhat.com --proxy-port 3128
Successfully created repository [puppet-repo]

[root@pulp-v2-server ~]# pulp-admin puppet repo sync run --repo-id puppet-repo 
+----------------------------------------------------------------------+
                 Synchronizing Repository [puppet-repo]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[==================================================] 100%
Metadata Query: 2/2 items
... completed

Downloading new modules...
[==================================================] 100%
Module: 38/38 items
... completed

Publishing modules...
[==================================================] 100%
Module: 38/38 items
... completed

Generating repository metadata...
[-]
... completed

Publishing repository over HTTP...
... completed

Publishing repository over HTTPS...
... skipped

From nectar.log

2013-10-07 09:20:54,349 urllib3.connectionpool:INFO: Starting new HTTP connection (1): pulp-proxy.usersys.redhat.com
2013-10-07 09:20:54,351 urllib3.connectionpool:INFO: Starting new HTTP connection (1): pulp-proxy.usersys.redhat.com
Comment 2 Corey Welton 2013-10-25 14:34:53 EDT
Testing notes:

katello-configure katello-configure --proxy-url http://host.example.com --proxy-port 3128 

also, --proxy-user and --proxy-pass for authentication testing.

non-authenticated testing in progress, authenticated will follow.
Comment 3 Corey Welton 2013-10-25 16:07:28 EDT
Retrieving content via unauthenticated proxy seems to work.  

However, bug #1021662 indicates that authenticated proxy is not presently working.  This is similar to what I'm seeing in katello, as well.
Comment 4 Corey Welton 2013-10-25 16:37:35 EDT
Failing this until we get a working pulp that can handle authenticated proxy.
Comment 5 Mike McCune 2013-11-01 14:47:19 EDT
moving ON_QA since https://bugzilla.redhat.com/show_bug.cgi?id=1021662 is VERIFIED and is included in 2.3.0-0.26.beta
Comment 6 Corey Welton 2013-11-01 16:12:25 EDT
Will mark this verified, insofar as ncsa auth goes for squid.  digest_pw method fails, and I'll write that up as a separate bz. 

pulp-server-2.3.0-0.26.beta.el6sat.noarch

Satellite-6.0.2-RHEL-6-20131101.0
Comment 9 Bryan Kearney 2014-04-24 13:09:13 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 10 Bryan Kearney 2014-04-24 13:10:46 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.