Bug 1017399 - System list returns error
System list returns error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Kedar Bidarkar
: Triaged
: 1017872 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 15:30 EDT by Justin Sherrill
Modified: 2014-04-24 13:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-10-09 15:30:08 EDT
Description of problem:

Within katello nightly go to Systems and wait for the list to load

It will return an error

How reproducible:
always

Steps to Reproduce:
1. Register one system
2. Go to Systems

Actual results:
No systems and an error


Expected results:
no error and a system


Additional info:

relevant traceback:

[ERROR 2013-10-09 15:28:13 app] NoMethodError: undefined method `to_a' for false:FalseClass
 | /home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/rabl-0.7.6/lib/rabl/engine.rb:138:in `collection'
 | /home/jlsherri/git/katello/app/views/api/v2/common/index.json.rabl:1:in `render'
 | /home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/rabl-0.7.6/lib/rabl/engine.rb:32:in `instance_eval'
 | /home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/rabl-0.7.6/lib/rabl/engine.rb:32:in `render'
 | /home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/rabl-0.7.6/lib/rabl/partials.rb:27:in `object_to_hash'
 | /home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/rabl-0.7.6/lib/rabl/partials.rb:14:in `partial'
 | /home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/rabl-0.7.6/lib/rabl/builder.rb:112:in `extends'
 | /home/jlsherri/.rvm/g
Comment 1 Justin Sherrill 2013-10-09 15:32:56 EDT
https://github.com/Katello/katello/pull/3149
Comment 4 Kedar Bidarkar 2013-10-10 12:42:00 EDT
*** Bug 1017872 has been marked as a duplicate of this bug. ***
Comment 5 Og Maciel 2013-10-10 12:57:25 EDT
FWIW also seeing it when browsing Products /katello/products#/products
Comment 7 Kedar Bidarkar 2013-10-16 07:33:58 EDT
Registered systems via cli are now visible via the web-UI.
Comment 8 Bryan Kearney 2014-04-24 13:11:16 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 9 Bryan Kearney 2014-04-24 13:12:13 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.