Bug 1017501 - Section should not need additional topics other than initial text
Section should not need additional topics other than initial text
Status: CLOSED NOTABUG
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 00:04 EDT by mmurray
Modified: 2013-10-10 00:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 00:26:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mmurray 2013-10-10 00:04:41 EDT
Description of problem:

Just as can have 'empty' chapters
Chapter: About this Release [24015]
Chapter: New Features [24020]
Chapter: Resolved Issues [24018]

should be able to have 'empty' sections
Section: About this Release [24015]
Section: New Features [24020]
Section: Resolved Issues [24018]

But UI gives validation errors that section must have topics. I assume this means:
Section: About this Release [24015]
  Topic1 [12345]
  Topic2 [12346]

^ Desired functionality of 'empty' sections is of use for articles and so Release Notes documents.
[Book with chapters and preface is too verbose for Release Notes. Article makes a better doc for Release Notes.]


Version-Release number of selected component (if applicable):
Build 201309081012
Comment 1 Lee Newson 2013-10-10 00:26:55 EDT
A topic is already a section, so doing that is just pointless and in this case you are just trying to workaround something that you shouldn't be. I suspect you don't know about the "Type" metadata, which is what you should be using for Articles. The "Type" metadata allows you to specify the book type, which in turn changes the validation rules and how the XML is built. An example of an Article Content Spec is:

Title = My Book
Product = My Product
Version = 1
Type = Article
Brand = JBoss
Copyright Holder = Red Hat, Inc

Goal [12563]
Reviewers [12579]
Deliverables [12981]
Resources [12565]
Schedule [12714]
Section: Documentation Plan
  Priority One Documentation Items [12852]
  Priority Two Documentation Items [12851]
  Priority Three Documentation Items [12853]
Alpha and Beta Documentation [13164]
Comment 3 mmurray 2013-10-10 00:41:59 EDT
I had already set
Type = Article

But I did not know that you could simply have a topic with prepending with Chapter or Section.

This is perfect.

Please close as not a bug.
Comment 4 Lee Newson 2013-10-10 00:53:57 EDT
Okay cool sorry about that then Michelle and I've created BZ#1017510 to try and clear that up in the Handbook, since I couldn't find any mention about it so there was no way you could have known.

Note You need to log in before you can comment on or make changes to this bug.