Bug 1017619 - Maven repo zip contains supported artifacts with invalid OSGi version
Summary: Maven repo zip contains supported artifacts with invalid OSGi version
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER3
: EAP 6.4.0
Assignee: Paul Gier
QA Contact: Nikoleta Hlavickova
URL:
Whiteboard:
Depends On:
Blocks: 1120790
TreeView+ depends on / blocked
 
Reported: 2013-10-10 09:00 UTC by Nikoleta Hlavickova
Modified: 2019-08-19 12:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 993037 None None None Never
Red Hat Bugzilla 1120790 None None None Never
Red Hat Bugzilla 1167393 None None None Never
Red Hat Bugzilla 1167394 None None None Never
Red Hat Bugzilla 1167398 None None None Never
Red Hat Bugzilla 1182973 None None None Never
Red Hat Bugzilla 1182974 None None None Never
Red Hat Bugzilla 1182975 None None None Never
Red Hat Bugzilla 1182979 None None None Never
Red Hat Bugzilla 1182980 None None None Never
Red Hat Bugzilla 1182981 None None None Never
Red Hat Bugzilla 1182983 None None None Never
Red Hat Bugzilla 1182984 None None None Never
Red Hat Bugzilla 1182985 None None None Never
Red Hat Bugzilla 1182989 None None None Never
Red Hat Bugzilla 1182990 None None None Never
Red Hat Bugzilla 1182991 None None None Never
Red Hat Bugzilla 1182992 None None None Never
Red Hat Bugzilla 1182993 None None None Never
Red Hat Bugzilla 1182994 None None None Never
Red Hat Bugzilla 1182995 None None None Never
Red Hat Bugzilla 1182996 None None None Never
Red Hat Bugzilla 1182997 None None None Never
Red Hat Bugzilla 1182998 None None None Never
Red Hat Bugzilla 1182999 None None None Never
Red Hat Bugzilla 1183000 None None None Never
Red Hat Bugzilla 1200401 None None None Never


Description Nikoleta Hlavickova 2013-10-10 09:00:13 UTC
There are 217 artifacts that do not meet the OSGi requirements in EAP 6.2.0 ER5 Maven repo zip. 

For full list of these artifacts see:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-Repository/job/eap-60-repository-maven-check-valid-versions/68/artifact/invalid-versions.txt

Comment 2 Kabir Khan 2014-11-13 22:50:07 UTC
AFAIK we OSGi is in tech preview, but I will test https://github.com/jbossas/jboss-eap/pull/1961 for merge anyway

Comment 3 Nikoleta Hlavickova 2014-11-21 11:44:12 UTC
There are still 107 failures in EAP 6.4.0.DR10 Maven repo zip, see:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP6-Repository/job/eap-6x-repository-maven-check-valid-osgi-versions/115/testReport/

Comment 4 Kabir Khan 2014-12-03 10:12:44 UTC
https://github.com/jbossas/jboss-eap/pull/2105

Comment 5 Lin Gao 2014-12-05 07:28:29 UTC
Second PR: https://github.com/jbossas/jboss-eap/pull/2125

There will be more components rebuilding coming soon. Maybe we can keep it as POST status for PR reference?

Comment 6 Nikoleta Hlavickova 2014-12-10 14:35:12 UTC
70 failures in EAP 6.4.0.DR13, see:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-repository-maven-check-valid-osgi-versions/123/testReport/

I can confirm that all artifacts from PR in comment 5 have now valid version.

Comment 10 Paul Gier 2014-12-16 21:52:53 UTC
Nikoleta,  can you update the test to provide results that look only at versions which affect a jar or zip file?  Many of the failures are POM only artifacts which could be difficult to remove from the repo without breaking dependency resolution, and should not have any effect on OSGi behaviour afaik.

Some of the other failures are related to unsupported artifacts which are used only for dependency resolution, and we'll work on fixing these by ER1 or ER2.

Comment 12 Kabir Khan 2014-12-22 13:01:10 UTC
I have merged https://github.com/jbossas/jboss-eap/pull/2174 but am unclear if that fixes everything or not. Still I have set to MODFIED, Paul please correct if that is a problem

Comment 13 Nikoleta Hlavickova 2015-01-06 13:34:29 UTC
List of affected jars for EAP 6.4.0.DR13 can be found here:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-repository-maven-check-valid-osgi-versions/124/artifact/invalid-versions-jars.txt

Total invalid versions: 70
Invalid versions affecting JAR artifacts only: 24

Comment 16 Paul Gier 2015-01-09 20:31:25 UTC
There are still a few more jars to merge, but it would be good to get updated test results to verify the remaining jars.  Plan to have this resolved for the next build.

Comment 17 Nikoleta Hlavickova 2015-01-12 13:10:58 UTC
There are 19 failures affecting JARs in EAP 6.4.0.ER1:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-6x-repository-maven-check-valid-osgi-versions/126/artifact/invalid-versions-jars.txt

Comment 18 Kabir Khan 2015-01-14 16:52:21 UTC
https://github.com/jbossas/jboss-eap/pull/2228

Comment 19 Kabir Khan 2015-01-14 16:53:48 UTC
Also https://github.com/jbossas/jboss-eap/pull/2231

Comment 20 Kabir Khan 2015-01-15 20:00:33 UTC
and https://github.com/jbossas/jboss-eap/pull/2237

Comment 21 Lin Gao 2015-01-16 02:38:53 UTC
And hopefully the last PR: https://github.com/jbossas/jboss-eap/pull/2245

Comment 24 Paul Gier 2015-02-10 22:15:12 UTC
Jenkins Invalid Versions             Notes
------------------------             ------

commons-lang-2.6-redhat-2            Supported version is 2.6.0.redhat-4
                                     Older version contained in old BOM

icu4j-49.1-redhat-1                  Not supported, transitive dep of lucene-icu

guava-13.0.1-redhat-1                Supported version is 13.0.1.redhat-2
                                     Old version is transitive dep of lucene

relaxngDatatype-2011.1-redhat-3      Supported version is 2011.1.0.redhat-9
                                     Older version contained in old BOM

commons-io-2.1-redhat-2              Supported version is 2.1.0.redhat-4
                                     Older version contained in old BOM

mimepull-1.2-redhat-2                Artifact is not supported
                                     Older version contained in old BOM

rhq-pluginAnnotations-3.0.4-redhat-2 Not supported, transitive dep 
                                     of remoting-jmx 1.1.3.Final-redhat-2

weld-spi-1.1.Final-redhat-5          Supported version is 1.1.0.Final-redhat-6

weld-api-1.1.Final-redhat-5          Supported version is 1.1.0.Final-redhat-6

jboss-el-1.0_02.CR5                  Unsupported, transitive dep of jboss-seam

javassist-3.18.1-GA-redhat-1         Supported version is 3.18.1.GA-redhat-1
                                     Transitive dep of remoting-jmx and 
                                     hibernate.

jaxb-api-2.1.4                       This version is valid OSGi
                                     Not sure why this was in test output

Comment 25 Paul Gier 2015-02-10 22:22:55 UTC
None of the remaining invalid versions are supported jars, and therefore would not be accessed when using the appropriate Maven dependency management with a BOM, so I don't consider this to be a blocker anymore.

The current build of remoting-jmx (1.1.3.Final-redhat-2), hibernate (4.2.18.Final-redhat-1), and lucene (3.6.2.redhat-7) are the cause of several of these issues because their poms directly reference the older transitive dependencies.

I propose that we look at updating/rebuilding these three, and ignore the other cases.

Comment 31 Paul Gier 2015-03-10 13:44:24 UTC
Created a new issue for the remaining non-blocking artifacts (bug #1017619).
Moving this issue back to ON_QA so the blocker portion of this issue can be closed.

Comment 33 Nikoleta Hlavickova 2015-03-12 08:15:36 UTC
Verified using EAP 6.4.0.ER3 bits: all EAP supported artifacts have valid OSGi version.


Note You need to log in before you can comment on or make changes to this bug.