Bug 1120790 - (6.3.z) Invalid OSGi artifact versions affecting Layered Platforms
Summary: (6.3.z) Invalid OSGi artifact versions affecting Layered Platforms
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
low
urgent
Target Milestone: CR1
: EAP 6.3.3
Assignee: Paul Gier
QA Contact: Nikoleta Ziakova
URL:
Whiteboard:
Depends On: 1017619
Blocks: 1118675 eap633-payload
TreeView+ depends on / blocked
 
Reported: 2014-07-17 17:10 UTC by kconner
Modified: 2015-01-22 10:49 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-22 10:49:52 UTC
Type: Bug


Attachments (Terms of Use)
List of problematic artifacts (8.05 KB, text/plain)
2014-07-17 17:10 UTC, kconner
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1017619 None None None Never

Internal Links: 1017619

Description kconner 2014-07-17 17:10:04 UTC
Discussion on the Wolf mailing list has highlighted a number of EAP artifacts that are being generated with invalid OSGi versions, a subset of which causes issues for FSW because they prevent us from installing into an OSGi environment and lead to failures such as

Error executing command: invalid version "1.6.2-redhat-4": non-numeric "2-redhat-4" 

(in this instance caused by joda-time)

This is blocking FSW work on Fuse, the primary reason for our 6.1 release, as we are unable to install features using productised versions of those artifacts.

At this stage there appears to be 22 productised artifacts that we are currently pulling in from the EAP distribution or maven repository.  The list of artifacts, versions and their paths (location when install in fuse, location in the EAP distribution and/or location in EAP maven repository) is attached.

Comment 1 kconner 2014-07-17 17:10:33 UTC
Created attachment 918785 [details]
List of problematic artifacts

Comment 3 Paul Gier 2014-07-22 20:14:00 UTC
This is something we have been working to fix over the last few releases.  It should be fully resolved in 6.4.  We can address specific problematic artifacts in the 6.3 patch stream if necessary.

Comment 4 kconner 2014-07-28 19:24:51 UTC
All the problematic artifacts are in the attachment, these affect the current FSW build.

Comment 7 Dominik Pospisil 2014-11-19 12:52:13 UTC
PR sent: https://github.com/jbossas/jboss-eap/pull/1962

Comment 8 Paul Gier 2014-11-20 14:31:20 UTC
staxmapper (1.1.0.Final) and jbossws-api (1.0.0.GA) appear to have valid OSGi versions.  Can you describe why these were included in the list?

Comment 11 Nikoleta Ziakova 2015-01-19 09:53:00 UTC
I can still see some of the problematic artifacts (from comment 1) in EAP 6.3.3.CP.CR1:

txw2-20110809-redhat-4
relaxngDatatype-2011.1-redhat-6
commons-cli-1.2.redhat-4
commons-lang-2.6.redhat-3
commons-io-2.1.redhat-3
joda-time-1.6.2-redhat-4
commons-codec-1.4.redhat-3
commons-configuration-1.6.redhat-3
jcip-annotations-1.0.redhat-6
mail-1.4.5-redhat-1
activation-1.1.1-redhat-2
commons-pool-1.6.redhat-6
apache-mime4j-0.6.redhat-3
snakeyaml-1.8-redhat-2
javassist-3.18.1-GA-redhat-1
commons-httpclient-3.1-jbossorg-1

For all invalid version affecting JAR artifacts see test results (please note the test run on the incremental Maven repository including also EAP 6.3.0.GA artifacts):
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/EAP6/view/EAP-6.3.x-CP/view/EAP-6.3.x-CP-jobs/job/eap-63x-patched-repository-maven-check-valid-osgi-versions/8/artifact/invalid-versions-jars.txt


Note You need to log in before you can comment on or make changes to this bug.