Bug 10177 - RedHat 6.1 locking up
RedHat 6.1 locking up
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: xlockmore (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
: 11935 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-14 19:49 EST by rltheis
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 14:09:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rltheis 2000-03-14 19:49:31 EST
RedHat 6.1 has locked up on me a number of times while I had lock screen
running. I had my system in lock screen for a number of hours when this
happens. For other programs running, it has veried from nothing to having
Applix, kpppload, kedit, and/or other programs running. The system has also
locked up while I was working. This has only happened a 2 to 4 times over
the last couple of months.
 Does RedHat supply the latest kernals in rpm format? Or do you know of a
site that does?

Thank you,
  Richard Theisen
Comment 1 rltheis 2000-04-13 20:31:59 EDT
Has this been looked into yet? A couple of days ago, I was running Netscape and
the hung twice within 10 minutes.

Thank you,
  Richard Theisen
Comment 2 Jeff Johnson 2000-05-14 16:58:59 EDT
Changing component to xlockmore ...
Comment 3 Bill Nottingham 2000-06-11 14:47:20 EDT
*** Bug 11935 has been marked as a duplicate of this bug. ***
Comment 4 Rob Kearey 2000-06-12 23:21:41 EDT
Note that this bug /only/ occurs in the "penetrate" screensaver. I'm not having
any lockup problems as per bug 10177.

I have an strace out if that would help.

Rob K
Comment 5 pdenis2 2000-06-25 15:09:05 EDT
"Penetrate" -- I assume that's the component of GNOME's "random screensaver" 
that leaves a garbled, orange, "Level 1 Cleared" screen -- is locking up 2 of my 
RH6.1 systems, requiring hard reset ( I couldn't even ping to it).  Different 
machines, different video cards.  Only recent change has been to run X at 100 
dpi instead of 75 dpi.  Questions: how to get rid of "penetrate" from system 
(rpm -e xscreensaver I assume).  How to turn on Magic sysreq (and where is it 
documented??!)
Comment 6 pdenis2 2000-06-27 14:09:52 EDT
The "penetrate" lockup occurs _ONLY_ when I run X in 100 dpi mode (startx -- 
-dpi 100).  Alt-sysrq-k will free it up to the extent of allowing a ctrl-alt-del 
reboot.
Comment 7 Bill Nottingham 2000-08-07 23:17:43 EDT
We've never seen this with penetrate here, or with xlock.

To remove it, you can a) pick a different screensaver
b) edit it out of /usr/X11R6/lib/X11/app-defaults/XScreenSaver
Comment 8 rltheis 2000-08-08 20:51:26 EDT
  After downloading my e-mail, I left my system running without starting xlock
and I had 5 terminals, 1 kpppload, 1 xosview, and 1 KDE World Watch View
running. When I turned my monitor back on, my system had locked up. I could not
change virtual windows or move the mouse. When I run xlock, I use the random
option and I've noticed the system locking up on different screen savers. The
only time I have not had a lock-up is when I logout and have the gui login
screen showing. In this case the KDE login screen.
  Is there anything I can run to trap any possible errors? I did not see
anything in /var/logs/messages that indicated any problem. Is there anything you
want me to try?

Thanks!
  Richard Theisen

Note You need to log in before you can comment on or make changes to this bug.