Bug 1017790 - vdagent-win gets stopped (restarted) after 10+ MB text is copied to the clipboard
vdagent-win gets stopped (restarted) after 10+ MB text is copied to the clipb...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-vdagent-win (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Uri Lublin
Desktop QE
: Regression
Depends On:
Blocks: 1017250 1029162
  Show dependency treegraph
 
Reported: 2013-10-10 09:59 EDT by David Jaša
Modified: 2014-06-09 08:51 EDT (History)
9 users (show)

See Also:
Fixed In Version: vdagent-win-3.4-1
Doc Type: Bug Fix
Doc Text:
Previously, attempting to copy text greater than 10 MB in size to the clipboard in Windows virtual machines caused vdagent-win to restart. This was caused by the error trapping logic for clipboard-related operations, which did not account for operations involving data greater than this size. Now, the error trapping logic for vdagent-win has been revised so that an error is displayed when the maximum clipboard size is exceeded, preventing vdagent-win from restarting when the maximum clipboard size is exceeded. Users also have the ability to specify the maximum clipboard size.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 08:51:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-10-10 09:59:28 EDT
Description of problem:
vdagent-win gets stopped (restarted) after 10+ MB text is copied to the clipboard

Version-Release number of selected component (if applicable):
vdagent-win-3.3-1 (from RHEV Tools 3.3-6)
windows 7 32bit

How reproducible:
100% in given VM

Steps to Reproduce:
1. copy 10+ MB plain text to a clipboard
2.
3.

Actual results:
vdagent gets stopped:
284::INFO::2013-10-10 13:18:43,260::VDAgent::write_completion::vio_serial write completion error 554
284::INFO::2013-10-10 13:18:43,260::VDAgent::run::Agent stopped
1976::INFO::2013-10-10 13:18:46,307::VDAgent::run::***Agent started in session 2***

Expected results:
vdagent keeps running and handles the failure

Additional info:
related bug: 1017302
Comment 1 David Jaša 2013-10-10 10:47:22 EDT
> related bug: 1017302
related bug: bug 1017302 (clickable)

virtio-serial bug: bug 1017817
Comment 3 David Blechter 2013-12-09 14:14:19 EST
I performed the following test connecting to 2 rhevm in westford:

1.1 running virt-viewer on my F18 machine;
1.2. connected to win 7 VM on rhevm 3.2 (  3.2.0-11.30.el6ev ).
1.3. Copy of 11 mb plain text from Guest to client WORKS!
1.4. Copy of 11 mb of plain text from the client to the quest failed.

now the same on rhvm 3.3:

2.1 running virt-viewer on my F18 machine;
2.2. connected to win 7 VM on rhevm 3.2 (   3.3.0-0.38.rc.el6ev ).
2.3. Copy of 11 mb plain text from Guest to client WORKS!
2.4. Copy of 11 mb of plain text from the client to the quest WORKS.

I just saw an improvement, not regression.
Comment 5 Marc-Andre Lureau 2014-03-11 14:24:31 EDT
Should probably be moved to POST:
http://lists.freedesktop.org/archives/spice-devel/2014-March/016295.html
Comment 6 Uri Lublin 2014-04-07 06:48:47 EDT
In addition to some improvements in the client, the fix in comment 5 enable users to limit the clipboard size.

On the client side an environment variable SPICE_MAX_CLIPBOARD can be defined.

The client communicates that number to the agent which will not send clipboard data of size larger than this number.
Comment 12 errata-xmlrpc 2014-06-09 08:51:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0645.html

Note You need to log in before you can comment on or make changes to this bug.