Bug 1017817 - copying of 10+ MB plaintext from guest through spice clipboard to client results in: vio_serial write completion error 554
Summary: copying of 10+ MB plaintext from guest through spice clipboard to client resu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: pre-dev-freeze
: 7.1
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-10 14:45 UTC by David Jaša
Modified: 2015-11-24 08:39 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:39:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description David Jaša 2013-10-10 14:45:48 UTC
Description of problem:
copying of 10+ MB plaintext from guest through spice clipboard to client results in: vio_serial write completion error 554

Version-Release number of selected component (if applicable):
guest:
  windows 7 64b
  vdagent-win-3.3.1 (from RHEV Tools >= 3.3-6)
  virtio-serial
  rhev-serial-msi-4.10-2

client:
  mingw-virt-viewer-0.5.6-6

How reproducible:
100 %

Steps to Reproduce:
1. select 10+ MB text in the guest (35 MB in my case)
2.
3.

Actual results:
agent gets this error:
284::INFO::2013-10-10 13:18:43,260::VDAgent::write_completion::vio_serial write completion error 554

and subsequently exits:
284::INFO::2013-10-10 13:18:43,260::VDAgent::run::Agent stopped
1976::INFO::2013-10-10 13:18:46,307::VDAgent::run::***Agent started in session 2***


Expected results:
no error is returned

Additional info:
  * combination of older virtio-serial (rhev-serial-msi-4.9-6) and RHEL 6.5 client works fine
  * vdagent-win bug to handle this virtio-serial bug: bug 1017790
  * the reproduces crashes the windows client as well: bug 1017302

Comment 1 Mike Cao 2013-10-11 02:16:24 UTC
Could you show me the virtio serial driver version you use ? seems it is too late to fix it in RHEL6.5.0 stage .Ronen ?

Comment 2 David Jaša 2013-10-11 07:03:57 UTC
(In reply to Mike Cao from comment #1)
> Could you show me the virtio serial driver version you use ? seems it is too
> late to fix it in RHEL6.5.0 stage .Ronen ?

As I wrote in description: rhev-serial-msi-4.10-2 (RHEV Tools 3.3-6), if I read brew logs correctly, it's based on virtio-win-1.6.6-1.el6.

Comment 3 lijin 2013-10-12 02:42:46 UTC
QE cannnot reproduce this issue in rhevm3.2.

After waiting for a long time,the 10+ MB text can be copied from guest to host,there was no error happened.

Comment 4 Mike Cao 2013-10-12 02:47:54 UTC
Tried start spice client on a win7-64 host

Actual Results:
if copy small texts ,it works fine 
When try to copy 10+MB text from guest to client host , there is no "paste" option on win7-64 host

Comment 5 lijin 2013-10-12 02:58:04 UTC
(In reply to lijin from comment #3)
> QE cannnot reproduce this issue in rhevm3.2.
> 
> After waiting for a long time,the 10+ MB text can be copied from guest to
> host,there was no error happened.

the package info:
host:rhel6.4
guest:win7-64
seabios-0.6.1.2-28.el6.x86_64
kernel-2.6.32-369.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.405.el6.x86_64
spice-vdagent-0.12.0-4.el6.x86_64
RHEV-Tools-3.2.13
virtio-win-prewhql-70

Comment 6 lijin 2013-10-12 07:54:10 UTC
upgrade RHEV-Tools to  RHEV-Tools-3.3-6,still cannot reproduce this issue

Comment 8 Gal Hammer 2013-10-13 12:04:01 UTC
It looks like it is a duplicate of bz#978404.

Comment 9 David Jaša 2013-10-14 08:01:09 UTC
(In reply to Mike Cao from comment #4)
> Tried start spice client on a win7-64 host
> 
> Actual Results:
> if copy small texts ,it works fine 
> When try to copy 10+MB text from guest to client host , there is no "paste"
> option on win7-64 host

When you look into %windir%\Temp\vdagent.log, you should see the driver error mentioned in #c0 there.

Comment 10 Mike Cao 2013-10-15 03:00:44 UTC
(In reply to David Jaša from comment #9)
> (In reply to Mike Cao from comment #4)
> > Tried start spice client on a win7-64 host
> > 
> > Actual Results:
> > if copy small texts ,it works fine 
> > When try to copy 10+MB text from guest to client host , there is no "paste"
> > option on win7-64 host
> 
> When you look into %windir%\Temp\vdagent.log, you should see the driver
> error mentioned in #c0 there.

Hi, David 

I did not find driver error in C:\windows\Temp\vdagent.log

Mike

Comment 15 Amnon Ilan 2015-08-04 20:37:59 UTC
Can you check please if it's reproducible with current versions?

Thanks,
Amnon

Comment 16 lijin 2015-08-13 06:09:34 UTC
with latest virtio-win-prewhql-109,QE didnot reproduce this issue.

packages info:
virtio-win-prewhql-109
rhev-guest-tools-iso-3.5-9.el6ev.noarch
qemu-kvm-rhev-0.12.1.2-2.479.el6.x86_64
kernel-2.6.32-572.el6.x86_64
seabios-0.6.1.2-30.el6.x86_64

Steps:
1.boot guest with:
/usr/libexec/qemu-kvm -enable-kvm -m 3G -smp 2 -nodefconfig -nodefaults -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -drive file=win7-64.raw,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso,if=none,id=drive-ide0-0-1,format=raw,cache=none,media=cdrom -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:0d:43:2e:66 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -monitor stdio -device virtio-serial-pci,id=virtio-serial0 -chardev socket,id=charchannel0,path=/tmp/com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/tmp/org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0 -cdrom /usr/share/rhev-guest-tools-iso/RHEV-toolsSetup_3.5_9.iso -spice disable-ticketing,port=5900 -vga qxl

2.install RHEV-toolsSetup.exe in guest
3.upgrade virtio-serial driver with virtio-win-prewhql-109 and reboot guest
3.select 30+ MB text in the guest
4.copy to host

actual result:
1.text can be copied correctly;
2.check guest vdagent log in c:\windows\Temp\vdagnet.txt,there is no error message.

Comment 21 lijin 2015-09-02 07:25:49 UTC
change status to VERIFIED according to comment#16 and comment#18

Comment 23 errata-xmlrpc 2015-11-24 08:39:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.