Bug 1017860 - Cannot connect to VMs on RHEL5 host
Cannot connect to VMs on RHEL5 host
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.5
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
: 813889 (view as bug list)
Depends On:
Blocks: 960054 1017862 1017864
  Show dependency treegraph
 
Reported: 2013-10-10 11:57 EDT by Christophe Fergeau
Modified: 2014-10-14 02:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: spice-gtk-0.22-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Protocol version fallback was broken Consequence: Could not connect to spice guests on RHEL5 servers Fix: Fix old protocol fallback. Result: Can connect to spice guests on RHEL5 servers again.
Story Points: ---
Clone Of:
: 1017862 1017864 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:46:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Fergeau 2013-10-10 11:57:14 EDT
Trying to connect to a RHEL5 VM causes a warning in the console '(remote-viewer:9644): GSpice-WARNING **: major mismatch (got 1, expected 2)' and an error message that it couldn't connect to the remote VM.
Tested with spice-gtk.x86_64 0:0.20-9.el6

This is fixed by http://lists.freedesktop.org/archives/spice-devel/2013-October/014897.html, scratch build with these 2 patches available from http://brewweb.devel.redhat.com/brew/taskinfo?taskID=6398063
Comment 1 Marc-Andre Lureau 2014-02-19 14:34:03 EST
*** Bug 813889 has been marked as a duplicate of this bug. ***
Comment 2 David Jaša 2014-02-20 07:51:28 EST
We have access to one VM running on RHEV2.2/RHEL5.y host --> qa_ack+

FWIW, connection works fine with F20 client (spice-gtk-0.23-1.fc20.x86_64) so the fix should work fine in RHEL6/7 as well once it makes its way to the builds...
Comment 5 errata-xmlrpc 2014-10-14 02:46:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1487.html

Note You need to log in before you can comment on or make changes to this bug.