Bug 101787 - random X crashes with i845 video chipset
random X crashes with i845 video chipset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-06 17:27 EDT by Marius Andreiana
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-26 15:10:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a part from /var/log/messages (36.78 KB, text/plain)
2003-08-06 17:28 EDT, Marius Andreiana
no flags Details
lspci -v -v (8.19 KB, text/plain)
2003-08-06 17:28 EDT, Marius Andreiana
no flags Details
/var/log/XFree86.0.log (55.53 KB, text/plain)
2003-08-09 01:36 EDT, Marius Andreiana
no flags Details
/etc/X11/XF86Config (3.09 KB, text/plain)
2003-08-09 01:37 EDT, Marius Andreiana
no flags Details

  None (edit)
Description Marius Andreiana 2003-08-06 17:27:32 EDT
a new system with gigabyte mb i845 chipset, intel celeron cpu, has random X
crashes (seldom). It happened once right after install when switching to text
mode with ctrl+alt+fn and it still happens after upgrading to glibc-2.3.2-27.9
from RH errata. It seems to happen more when Gnome Meeting is running ( with a
tv tuner as video device ).

I also have alsa drivers installed now, but it crashed before too.

stuff from /var/log/messages with [drm] which I also got on console other times
it crashed:
Aug  7 00:12:32 marte kernel: [drm:i830_wait_ring] *ERROR* space: 131048 wanted
131064
Aug  7 00:12:32 marte kernel: [drm:i830_wait_ring] *ERROR* lockup
Aug  7 00:12:43 marte kernel: [drm:i830_wait_ring] *ERROR* space: 131040 wanted
131064
Aug  7 00:12:43 marte kernel: [drm:i830_wait_ring] *ERROR* lockup
Aug  7 00:12:48 marte kernel: Unable to handle kernel NULL pointer dereference
at virtual address 00000078


I'll attach more info from /var/log/messages ( boot and crash )

What other info should I provide? Should I run a memory test with memtest86? (
for how long? )

Thank you
Comment 1 Marius Andreiana 2003-08-06 17:28:14 EDT
Created attachment 93460 [details]
a part from /var/log/messages
Comment 2 Marius Andreiana 2003-08-06 17:28:38 EDT
Created attachment 93461 [details]
lspci -v -v
Comment 3 Marius Andreiana 2003-08-06 17:55:36 EDT
here's another report of the same bug, more detailed:
http://www.uwsg.iu.edu/hypermail/linux/kernel/0305.0/0533.html

There are other reports on google, but I couldn't find additional info
Comment 4 Marius Andreiana 2003-08-07 13:31:00 EDT
Comment from the reporter on LKML:
--
No, I didn't receive any naswer, but it almost solved by not using frame 
buffer in the console.

I also moved to 2.6.0-test2 and it works much better.
--
So should this be closed as it's said to work in 2.6.0 ?
Comment 5 Mike A. Harris 2003-08-08 18:46:23 EDT
The problem above is a kernel bug as shown by:

Aug  7 00:12:48 marte kernel: Unable to handle kernel NULL pointer dereference
at virtual address 00000078

The following message:  [drm:i830_wait_ring] *ERROR* lockup
is frequently reported.  My assumption is that the i810 DRM is buggy.

Attach your X server log, config file, and kernel log (/var/log/messages)
Comment 6 Mike A. Harris 2003-08-08 18:48:30 EDT
Just as a note, the 2.6.0-test2 kernel has a different DRM, one which is far more
up to date than ours.  I would assume that if it works properly for you that
it is due to the new DRM.  I've no idea however if we'll be updating our DRM
for 2.4.x again or not, but it is possible theoretically anyway.
Comment 7 Marius Andreiana 2003-08-09 01:36:16 EDT
Created attachment 93544 [details]
/var/log/XFree86.0.log

As it has no dates in it, I couldn't trim it to the period when the crash
occured
Comment 8 Marius Andreiana 2003-08-09 01:37:00 EDT
Created attachment 93545 [details]
/etc/X11/XF86Config
Comment 9 Marius Andreiana 2003-08-09 01:40:28 EDT
/var/log/messages was already attached in the initial report.

>My assumption is that the i810 DRM is buggy
The hardware or kernel software?

About backporting 2.6 DRM to 2.4, I think your time would be better spent
improving 2.6 so we can upgrade faster to it.
Comment 10 Marius Andreiana 2003-11-09 10:55:23 EST
how to replicate in Fedora Core 1: in X press Ctrl+Alt+F1 to get to a
console. X will crash

I'll try a 2.6 kernel from arjan when a RPM is available for FC1.
Comment 11 Need Real Name 2003-11-12 02:26:26 EST
I have two dell gx260 running fc1. I have no problems with Ctrl+Alt+F1.

Machine A is running gnome, machine B is running kde. 

A is crashing a few times every day. All crashes happens when the
machine isn't being used. Screensaver turned off.

I have had no problems with B running kde. Yesterday, I switched to
gnome just for testing. This morning it had crashed...

Is there any way to turn off DRI? I really don't care about
performance, if thats the problem?
Comment 12 Adrian Miranda 2003-11-13 00:28:35 EST
I believe I am seeing the same problems described above.  I have tried
Fedora Core on a Dell GX260 and a GX60, both of which have the 845G
onboard video, and both have the same problem.  For a while X works
fine, but after a couple hours the screen goes black with a few lines.
 It never seems to die while I'm using it.  The system is still up,
you can ssh in, but you can't switch the virtual console or clear the
monitor.  According to the logs, the X server is just restarting
itself constantly.  In the messages file you see:

  kernel: [drm:i830_wait_ring] *ERROR* lockup
  kernel: [drm:i830_wait_ring] *ERROR* space: 130976 wanted 131064

In the X log, you see messages like:

  Error in I830WaitLpRing(), now is 45602, start is 43601

Hitting SHIFT-ALT-F1 does not cause any problems.  I haven't tried
running KDE yet, but I will.  

Please let me know if there is anything else I can tell you, or if
there are other tests I can run.
Comment 13 Need Real Name 2003-11-13 15:38:42 EST
Not a solution, but...

It looks like disabling xscreensaver in gnome is a good thing. No
crash in 2 days now, with xscreensaver it crashed a few times every
day. This is probably also why you don't see X crashing while using
your pc, and why using kde seems to be a better option for me.
Comment 14 Thomas Huining Feng 2003-12-17 16:43:43 EST
I have exactly the same problem. My video card is Intel 830, which my
Fedora rightly guess. But X usually crashes with the above error. I
then switch the setting to i865 and it's much better now. However,
when I'm playing video with mplayer and switch to text mode with
alt+ctrl+f1, X crashes again ...

I've tried to install kernel 2.6, but the screen just shows nothing
(even worse than 2.4)!
Comment 15 Mike A. Harris 2004-05-05 11:40:39 EDT
The latest rawhide kernel has i8xx DRM fixes which are believed
may resolve this issue.  Details can be found in bug #119311.  Please
test Fedora Core 2 test3 fully updated with the latest rawhide updates,
and see if the problem is resolved for you with this new kernel or not.

Setting bug status to "MODIFIED" pending user testing.  Please change
status to "RAWHIDE" if the problem is resolved now, or back to
"ASSIGNED" if it persists.
Comment 16 Marius Andreiana 2004-09-26 15:10:55 EDT
FC2 worked for me... Now digging fc3t2

Note You need to log in before you can comment on or make changes to this bug.