Bug 119311 - (i8xx-drm) [i845 drm] X lockup with 3D screensaver
[i845 drm] X lockup with 3D screensaver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
: 121846 (view as bug list)
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-29 06:09 EST by vvs
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-05 11:51:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DRM messages (5.80 KB, text/plain)
2004-03-29 06:10 EST, vvs
no flags Details
Xserver messages (51.63 KB, text/plain)
2004-03-29 06:10 EST, vvs
no flags Details
Xserver configuration (3.13 KB, text/plain)
2004-03-29 06:11 EST, vvs
no flags Details
DRM messages (1.72 KB, text/plain)
2004-04-09 09:06 EDT, vvs
no flags Details
Xserver messages (51.15 KB, text/plain)
2004-04-09 09:08 EDT, vvs
no flags Details

  None (edit)
Description vvs 2004-03-29 06:09:03 EST
Description of problem:

3D screensaver caused lockup of Xserver. My configuration:

Compaq Evo D310vm
Intel 845G

Version-Release number of selected component (if applicable):

xorg-x11-0.0.6.6-0.0.2004_03_11.9
kernel-2.6.4-1.290

How reproducible:

Always

Steps to Reproduce:
1. run xscreensaver-demo
2. select any 3D screensaver (e.g. AntSpotlight)
  
Actual results:

Xserver locks-up

Expected results:

Shouldn't be

Additional info:

This happens 100% with the latest Arjan's kernel and sporadically
happened with older kernels. It happen with latest xorg-x11 and with
older XFree86 releases too. That makes use of 3D graphics with Intel
8x5G chipsets impossible with 2.6 kernel.

There were similar bug reports in bugzilla:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119301
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=117713
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=101787
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=84097

But they lack some information and I prefer to open it as new with
logs attached.
Comment 1 vvs 2004-03-29 06:10:10 EST
Created attachment 98919 [details]
DRM messages
Comment 2 vvs 2004-03-29 06:10:39 EST
Created attachment 98920 [details]
Xserver messages
Comment 3 vvs 2004-03-29 06:11:14 EST
Created attachment 98921 [details]
Xserver configuration
Comment 4 Arjan van de Ven 2004-04-06 06:31:35 EDT
I fixed one bug in the i830 drm code (doubtless there are more); do
later kernels work better for you ?
Comment 5 vvs 2004-04-07 03:31:17 EDT
Nope :-( The same story.

kernel-2.6.4-1.305
xorg-x11-0.6.6-0.2004_03_30.1
Comment 6 vvs 2004-04-09 05:48:37 EDT
Latest kernel hit the spot :-) It works now.

kernel-2.6.5-1.308
xorg-x11-0.6.6-0.2004_03_30.5

I will watch if that bug won't show again sporadically and I'll report
it here later.
Comment 7 vvs 2004-04-09 09:03:36 EDT
Unfortunately it still locks-up sometimes during Xserver startup. But
it's not related to 3D screensaver anymore and it's fairly usable now.
I've attached new logs.
Comment 8 vvs 2004-04-09 09:06:30 EDT
Created attachment 99265 [details]
DRM messages
Comment 9 vvs 2004-04-09 09:08:56 EDT
Created attachment 99266 [details]
Xserver messages
Comment 10 vvs 2004-04-15 06:39:04 EDT
Well, recent kernels broke it again:

kernel-2.6.5-1.322

But now it locks-up cold, I can't even shutdown system cleanly.
Hitting power button don't work anymore as it did before (I have
acpi=on and acpid running). And so it was not possible to get log
messages because they were lost.
Comment 11 Alan Cox 2004-05-03 11:44:02 EDT
*** Bug 121846 has been marked as a duplicate of this bug. ***
Comment 12 vvs 2004-05-04 08:59:35 EDT
Unfortunately it doesn't work with kernel-2.6.5-1.349 either, sorry.
Comment 13 Arjan van de Ven 2004-05-04 13:14:48 EDT
ok 350 has this fixed 99% sure; I found out my testbox actually has a
865 chip which gets visible when I remove the AGP radeon ...
Comment 14 vvs 2004-05-05 09:30:01 EDT
Yes, you are right, kernel-2.6.5-1.350 actually has this fixed. Thank
you very much!
Comment 15 Alan McKay 2004-08-03 20:25:23 EDT
I'm running Fedora Tettnang release as downloaded 2 weeks ago, and
this problem still seems to be there except it comes up more randomly.
 And given that I run the machine 24x7 and have only seen the problem
when the saver kicks in, I have to assume that it only locks up the
machine if you try to use the machine while the particular SS is
active.  i.e. if you let the problem SS run it's course (e.g. while
I'm gone all day) and let the next one start, it's fine.  Maybe that's
an invalid assumption.

I've had it happen twice now.  Sorry, don't recall which saver it was
either time.  First time when I moved the mouse to deactive the saver
text appeared in the top left of the screen.  i.e. it was console text
coming out over top of the X server as though X were not even running
if you get what I mean.  I could still move the mouse and alt-tab
windows - for a bit.  Then things locked up completely.  But when I
hit the power button X came down and then I had the regular clean
Linux shutdown with all the "blah blah blah ..... [OK]"

The second time was just a few minutes ago and there was no console
text coming through, and it was hung tight from the beginning and the
power button seemed to initiate a shutdown but I didn't get all the
"blah blah blah ..... [OK]" - a few lines of shutdown text came up
then the power went out.  On reboot filesystems were clean though.

I've got an Nvidea Gforce (440 I think) video card, and an ASUS mobo
either  A7N8X-X or A7V8X-X don't recall of the top of my head.  

Dunno if this should reopen this bug or if there is somewhere else for
this to go. My apologies if I did the wrong thing but this was the
closest I could find.
Comment 16 Eric Raymond 2004-11-13 17:54:41 EST
I'm seeing what looks like the same problem (X lockup on 3D
screensaver) under a stock FC3 with a 2.6.9 kernel, ATI Radeon card.
It did not occur under FC2.

Note You need to log in before you can comment on or make changes to this bug.