Bug 1017921 - cli: node sync: reports "Sync complete" when sync hasn't finished on the node
cli: node sync: reports "Sync complete" when sync hasn't finished on the node
Status: CLOSED DUPLICATE of bug 1018236
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 14:46 EDT by Brad Buckingham
Modified: 2014-01-27 09:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 08:26:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2013-10-10 14:46:01 EDT
Description of problem:

The Satellite CLI reports "Sync Complete" for "node sync"; however, the node appears to be continuing to sync content.  This can be confusing to the user.

Version-Release number of selected component (if applicable):
katello-1.4.6-21.el6sat.noarch
katello-cli-1.4.3-18.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch

How reproducible:
So far, I've seen this occur on 1 out of 3 nodes; therefore, reproducing it might be tricky.

Steps to Reproduce:

1. Install/configure Satellite 6 (katello-configure)
2. Import a manifest, enable & sync RHEL 6Server
3. Create a content view definition, adding the repo from 3
4. Publish a content view from the definition

5. Install/configure Satellite 6 node (node-installer)
6. Using the CLI on the Satellite 6, add Library to the node.  E.g, 
   node add_environment --org Katello_Infrastructure --environment Library --id 1
7. Sync the Library to the node
   node sync --org Katello_Infrastructure --environment Library --id 1

Actual results:

After some time, CLI reports: 
Sync Complete                                         

However, the node appears to be continuing to sync content.  E.g.
 
pulp-admin -u [user] -p [password] tasks details --task-id 1fe27def-5c4c-44e6-aba7-4e9b2634c90c
+----------------------------------------------------------------------+
                              Task Details
+----------------------------------------------------------------------+

Operations:   sync
Resources:    Katello_Infrastructure-Red_Hat_Enterprise_Linux_Server-Red_Hat_Ent
              erprise_Linux_6_Server_RPMs_x86_64_6Server (repository)
State:        Running
Start Time:   2013-10-10T12:47:15Z
Finish Time:  Incomplete
Result:       Incomplete
Task Id:      1fe27def-5c4c-44e6-aba7-4e9b2634c90c
Progress:     
  Nodes Http Importer: 
    Repo Id:  Katello_Infrastructure-Red_Hat_Enterprise_Linux_Server-Red_Hat_Ent
              erprise_Linux_6_Server_RPMs_x86_64_6Server
    State:    adding_units
    Unit Add: 
      Completed: 3316
      Details:   /var/lib/pulp/content/rpm/selinux-policy/3.7.19/93.el6/noarch/e
                 ad049fa1f26b929a935f8d25e1e3f0a486827e7/Packages/selinux-policy
                 -3.7.19-93.el6.noarch.rpm
      Total:     13169


[root@sat-perf-05 rhel]# pulp-admin -u [user] -p [password] tasks details --task-id 1fe27def-5c4c-44e6-aba7-4e9b2634c90c
+----------------------------------------------------------------------+
                              Task Details
+----------------------------------------------------------------------+

Operations:   sync
Resources:    Katello_Infrastructure-Red_Hat_Enterprise_Linux_Server-Red_Hat_Ent
              erprise_Linux_6_Server_RPMs_x86_64_6Server (repository)
State:        Running
Start Time:   2013-10-10T12:47:15Z
Finish Time:  Incomplete
Result:       Incomplete
Task Id:      1fe27def-5c4c-44e6-aba7-4e9b2634c90c
Progress:     
  Nodes Http Importer: 
    Repo Id:  Katello_Infrastructure-Red_Hat_Enterprise_Linux_Server-Red_Hat_Ent
              erprise_Linux_6_Server_RPMs_x86_64_6Server
    State:    adding_units
    Unit Add: 
      Completed: 3770
      Details:   /var/lib/pulp/content/rpm/initscripts/9.03.23/1.el6/x86_64/2ba3
                 1c42345159643b07df6b95081db2870d3eb7/Packages/initscripts-9.03.
                 23-1.el6.x86_64.rpm
      Total:     13169

Expected results:

The CLI shouldn't report the sync as complete until all tasks associated have been completed.

Additional info:

This was observed on a production install.  It is possible that this issue was triggered by the low timeout values in /etc/pulp/server.conf (e.g. update_timeout: 10:600).  In other words the Satellite 6 server may have timed out at the 600s, while the agent on the node continued syncing.
Comment 2 Corey Welton 2013-10-14 14:16:32 EDT
Possibly related (or not) https://bugzilla.redhat.com/show_bug.cgi?id=1018236
Comment 3 Brad Buckingham 2013-10-16 08:26:29 EDT
The root cause of this bug and bug 1018236 are the same.  Closing this once, since the other was opened by QA. :)

*** This bug has been marked as a duplicate of bug 1018236 ***

Note You need to log in before you can comment on or make changes to this bug.