Bug 1018236 - node sync silently fails/says success when there obviously isn't any.
node sync silently fails/says success when there obviously isn't any.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Katello QA List
: Triaged
: 1017921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 10:13 EDT by Corey Welton
Modified: 2014-04-24 13:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:07:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-10-11 10:13:46 EDT
Description of problem:

We're telling users a sync was successful even if there's no way it could be.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create a child node from parent but don't actually complete process on child side (i.e., run node-install) -- or assure there's something that causes the install to fail on child.
2.  katello --user admin --password admin node sync --id 1
3. View results.

Actual results:
[root@ibm-x3500m4-01 ~]# katello --user admin --password admin node --help
Usage:  katello options node command
Supported Commands:
	add_environment add an environment
	list           list all known nodes
	remove_environment remove an environment
	sync           Sync a node

Options:
  -h, --help  show this help message and exit
[root@ibm-x3500m4-01 ~]# katello --user admin --password admin node sync --id 1
Sync Complete                   


Expected results:
The text implies that we're performing some sort of sync against child node - but if nothing is taking place and/or if it failed, we shouldn't just say "sync complete".


Additional info:
Comment 2 Justin Sherrill 2013-10-15 09:42:10 EDT
I don't think this is really a 'high' priority, but will take a look.
Comment 3 Brad Buckingham 2013-10-16 08:26:29 EDT
*** Bug 1017921 has been marked as a duplicate of this bug. ***
Comment 4 Brad Buckingham 2013-10-16 08:32:36 EDT
katello-cli pull request: 
https://github.com/Katello/katello-cli/pull/109

The the output should now be similar to the following:

katello> node sync --org ACME_Corporation --environment dev --id 1
Sync of environment [ dev ] completed successfully.

# if the child node was down (e.g. httpd not running on node)
katello> node sync --org ACME_Corporation --environment dev --id 1
Sync of environment [ dev ] failed:[Errno 111] Connection refused
Comment 7 Corey Welton 2013-10-23 15:57:05 EDT
QA Verified in Satellite-6.0.2-RHEL-6-20131021.0
Comment 10 Bryan Kearney 2014-04-24 13:07:52 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.