Bug 1018073 - Cannot connect to the mysql/psql database for existing scalable apps after migration on STG
Cannot connect to the mysql/psql database for existing scalable apps after mi...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 02:58 EDT by Meng Bo
Modified: 2015-05-14 19:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:35:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-10-11 02:58:09 EDT
Description of problem:
After stage upgrade to devenv-stage_493, existing scalable apps cannot connect to the mysql/psql db anymore.

Version-Release number of selected component (if applicable):
STG(devenv-stage_493)

How reproducible:
always

Steps to Reproduce:
1.Create scalable app with mysql and postgresql added
2.STAGE upgrade
3.Try to connect to the mysql/psql from the scalable app

Actual results:
\> mysql
ERROR 1130 (HY000): Host 'ip-10-179-2-61.ec2.internal' is not allowed to connect to this MySQL server
\> psql
psql: FATAL:  no pg_hba.conf entry for host "10.179.2.61", user "adminfsrygr7", database "jbeap1s", SSL off

\> hostname
ex-std-node3.stg.rhcloud.com
\> ping ex-std-node3.stg.rhcloud.com
PING ex-std-node3.stg.rhcloud.com (10.179.2.61) 56(84) bytes of data.

Expected results:
The dbs can be connected from the scalable app web gear. 

Additional info:
It works fine on the INT after server upgrade.

The dbs can be connected from the rhcsh on the db-gear.

[52135d8ddbd93cdda6000657-bmeng1stg.stg.rhcloud.com 52135d8ddbd93cdda6000657]\> mysql
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 2
Server version: 5.1.69 Source distribution

Copyright (c) 2000, 2013, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
Comment 1 Meng Bo 2013-10-11 05:01:24 EDT
Tested on a single node upgrade to devenv-stage_493 from devenv-stage_486.

The mysql/psql db can be connected for scalable app.
Comment 2 Xiaoli Tian 2013-10-11 06:46:46 EDT
I doubt this might be  still caused  by cartridge_version number has not been upgraded for sprint34 (similar to  bug 1018134), which cause most changes for the cartridges  have not been upgraded in STG  since STG is running oo-admin-upgrade without --ignore-cartridge-version option.
Comment 3 Meng Bo 2013-10-11 22:47:02 EDT
Tested on current STG (devenv-stage_496), cannot reproduce this issue.
Comment 4 Meng Bo 2013-10-15 01:31:57 EDT
Bug fixed on STG, move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.