Bug 1018076 - [RHS-C]: Error while executing action RefreshGlusterHooks: Internal Engine Error [NEEDINFO]
[RHS-C]: Error while executing action RefreshGlusterHooks: Internal Engine Error
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: Timothy Asir
Prasanth
: ZStream
Depends On:
Blocks: 999795 1028982
  Show dependency treegraph
 
Reported: 2013-10-11 03:07 EDT by Prasanth
Modified: 2015-05-13 12:31 EDT (History)
9 users (show)

See Also:
Fixed In Version: CB5
Doc Type: Bug Fix
Doc Text:
Previously, an error message was displayed during Gluster Syn and the operation was failing. Now, with this update, the issue is fixed to allow Gluster Sync and all the hooks are listed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:51:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sharne: needinfo? (tjeyasin)


Attachments (Terms of Use)
screenshot of error (98.22 KB, image/png)
2013-10-11 03:07 EDT, Prasanth
no flags Details

  None (edit)
Description Prasanth 2013-10-11 03:07:18 EDT
Created attachment 810886 [details]
screenshot of error

Description of problem:

Sync hooks is failing with: "Error while executing action RefreshGlusterHooks: Internal Engine Error". Following is seen in the vdsm.log:

----------------------
Thread-1241::DEBUG::2013-10-11 12:34:42,659::BindingXMLRPC::974::vds::(wrapper) client [10.70.36.80]::call hooksList with () {}
Thread-1241::ERROR::2013-10-11 12:34:42,661::BindingXMLRPC::993::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 979, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/gluster/api.py", line 53, in wrapper
    rv = func(*args, **kwargs)
  File "/usr/share/vdsm/gluster/api.py", line 242, in hooksList
    status = self.svdsmProxy.glusterHooksList()
  File "/usr/share/vdsm/supervdsm.py", line 50, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 48, in <lambda>
    **kwargs)
  File "<string>", line 2, in glusterHooksList
  File "/usr/lib64/python2.6/multiprocessing/managers.py", line 740, in _callmethod
    raise convert_to_error(kind, result)
AttributeError: 'module' object has no attribute 'MIME_TYPE'
Thread-1246::DEBUG::2013-10-11 12:34:55,557::task::579::TaskManager.Task::(_updateState) Task=`ebc82f54-1798-4110-8c4d-8fbcdf8382b6`::moving from state init -> state preparing
----------------------


Version-Release number of selected component (if applicable): 

----------------------
[root@vm08 /]# rpm -qa |grep rhsc
rhsc-2.1.1-0.0.3.master.el6ev.noarch
rhsc-lib-2.1.1-0.0.3.master.el6ev.noarch
rhsc-webadmin-portal-2.1.1-0.0.3.master.el6ev.noarch
rhsc-sdk-2.1.0.0-0.bb3a.el6rhs.noarch
rhsc-log-collector-2.1-0.1.el6rhs.noarch
rhsc-tools-2.1.1-0.0.3.master.el6ev.noarch
rhsc-backend-2.1.1-0.0.3.master.el6ev.noarch
rhsc-cli-2.1.0.0-0.bb3a.el6rhs.noarch
rhsc-restapi-2.1.1-0.0.3.master.el6ev.noarch
rhsc-dbscripts-2.1.1-0.0.3.master.el6ev.noarch
rhsc-branding-rhs-3.3.0-1.0.master.201309200500.fc18.noarch
rhsc-setup-2.1.1-0.0.3.master.el6ev.noarch

[root@vm10 /]# rpm -qa |grep vdsm
vdsm-python-cpopen-4.12.0-178.git42c732a.el6.x86_64
vdsm-gluster-4.12.0-178.git42c732a.el6.noarch
vdsm-python-4.12.0-178.git42c732a.el6.x86_64
vdsm-xmlrpc-4.12.0-178.git42c732a.el6.noarch
vdsm-cli-4.12.0-178.git42c732a.el6.noarch
vdsm-4.12.0-178.git42c732a.el6.x86_64
----------------------

How reproducible: Always


Steps to Reproduce:
1. Select the Cluster having hosts added
2. Click on "GlusterHooks" sub-tab
3. Click on Sync and watch the error

Actual results: Sync is failing with the following error:

---
Error while executing action RefreshGlusterHooks: Internal Engine Error
---


Expected results: Sync hooks should be successful


Additional info: Screenshot of error and sosreport attached
Comment 3 Timothy Asir 2013-10-16 08:39:01 EDT
The fix patch is already available in downstream url:
https://code.engineering.redhat.com/gerrit/gitweb?p=rhs-vdsm.git;a=commit;h=a06e36029d7bb0821d53abda19579a1445027122
Comment 4 Timothy Asir 2013-10-22 02:26:48 EDT
Fix patch sent to downstream
Comment 5 Prasanth 2013-10-28 03:16:44 EDT
Verified as fixed in cb5.

Sync is now listing all the hooks.
Comment 6 Shalaka 2014-01-06 06:49:22 EST
Please review the edited DocText and confirm.
Comment 8 errata-xmlrpc 2014-02-25 02:51:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.