Bug 1018146 - [HHH-8605] ManyToManyTest.testManyToManyWithFormula fails on mssql2008R2, mssql2012, sybase157
[HHH-8605] ManyToManyTest.testManyToManyWithFormula fails on mssql2008R2, mss...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER7
: EAP 6.2.0
Assigned To: Brett Meyer
Zbyněk Roubalík
Russell Dickenson
:
Depends On:
Blocks: 1022581
  Show dependency treegraph
 
Reported: 2013-10-11 06:42 EDT by Martin Simka
Modified: 2015-09-01 00:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On Sybase and Microsoft SQL Server, HQL queries which had tuples in subqueries would throw exceptions. Neither Sybase nor Microsoft SQL Server support tuples in subqueries, such as the following query: `delete from Table1 where (col1, col2) in (select col1, col2 from Table2)` This issue occurred because the Hibernate dialects for Sybase and Microsoft SQL Server did not configure the `supportsTuplesInSubqueries` property to `false`. In this release of JBoss EAP 6, the Hibernate dialects for Sybase and Microsoft SQL Server have been updated to accurately reflect the lack of support for tuples in subqueries. As a result, warnings are now produced rather than throwing exceptions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:19:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simka 2013-10-11 06:42:27 EDT
Hibernate-orm 4.2.6

org.hibernate.test.manytomany.ManyToManyTest.testManyToManyWithFormula fails on mssql2008R2, mssql2012

https://hibernate.atlassian.net/browse/HHH-8605

It didn't fail with 4.2.5
Comment 1 Brett Meyer 2013-10-14 10:38:51 EDT
Legitimate issue stemming from https://hibernate.atlassian.net/browse/HHH-8476. sqlserver/sybase do not support tuples in subqueries (ex: "delete from Table1 where (col1, col2) in (select col1, col2 from Table2)"). The fix for HHH-8476 was skipped and logged where the tuples were not supported, but not all dialects had been audited (our matrix job has been a mess lately).

This should be noted as a known issue for EAP 6.2 and the databases should still be certified.  Operationally, nothing is "wrong" -- the HHH-8476 fix is simply throwing an exception rather than warning.
Comment 2 Brett Meyer 2013-10-23 11:26:27 EDT
Included in upgrade to Hibernate ORM 4.2.7.Final under 1022581.
Comment 3 Martin Simka 2013-11-08 06:05:05 EST
verified on EAP 6.2.0.ER7

Note You need to log in before you can comment on or make changes to this bug.