Bug 1018170 - quota: numbers of warning messages in nfs.log a single file itself
quota: numbers of warning messages in nfs.log a single file itself
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
2.1
Unspecified Linux
medium Severity high
: ---
: RHGS 3.1.2
Assigned To: Manikandan
Matt Zywusko
: EasyFix, Reopened, ZStream
Depends On: 1254146 1262344
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2013-10-11 07:12 EDT by Saurabh
Modified: 2016-09-20 00:29 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-0.3
Doc Type: Bug Fix
Doc Text:
Previously, in NFS, there were several log messages duplicated. With this fix, duplicate logs are removed which results in lesser logs.
Story Points: ---
Clone Of:
: 1254146 (view as bug list)
Environment:
Last Closed: 2016-03-01 00:21:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-10-11 07:12:19 EDT
Description of problem:
set the quota limit 
started creating data 
in nfs.log there are loads of waring messages.


Version-Release number of selected component (if applicable):
glusterfs-3.4.0.34rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1. create and start a volume
2. enable and set quota limit of 1GB on "/"
3. mount over nfs on a client
4. start creating data inside the mount-point

Actual results:
there are many Warning messages for a single itself, after quota limit is reached.
Example,

[2013-10-11 16:36:29.380171] W [nfs3.c:2075:nfs3svc_write_cbk] 0-nfs: 15f4dce6: /f.195 => -1 (Disk quota exceeded)
[2013-10-11 16:36:29.380258] W [nfs3-helpers.c:3443:nfs3_log_write_res] 0-nfs-nfsv3: XID: 15f4dce6, WRITE: NFS: 69(Resource (quota) hard limit exceeded), POSIX: 122(Disk quota exceeded), count: 0, UNSTABLE,wverf: 1381508849
[2013-10-11 16:36:29.383242] W [nfs3.c:2075:nfs3svc_write_cbk] 0-nfs: 16f4dce6: /f.195 => -1 (Disk quota exceeded)
[2013-10-11 16:36:29.383278] W [nfs3-helpers.c:3443:nfs3_log_write_res] 0-nfs-nfsv3: XID: 16f4dce6, WRITE: NFS: 69(Resource (quota) hard limit exceeded), POSIX: 122(Disk quota exceeded), count: 0, UNSTABLE,wverf: 1381508849
[2013-10-11 16:36:29.386541] W [nfs3.c:2075:nfs3svc_write_cbk] 0-nfs: 17f4dce6: /f.195 => -1 (Disk quota exceeded)
[2013-10-11 16:36:29.386577] W [nfs3-helpers.c:3443:nfs3_log_write_res] 0-nfs-nfsv3: XID: 17f4dce6, WRITE: NFS: 69(Resource (quota) hard limit exceeded), POSIX: 122(Disk quota exceeded), count: 0, UNSTABLE,wverf: 1381508849
[2013-10-11 16:36:29.389726] W [nfs3.c:2075:nfs3svc_write_cbk] 0-nfs: 18f4dce6: /f.195 => -1 (Disk quota exceeded)
[2013-10-11 16:36:29.389782] W [nfs3-helpers.c:3443:nfs3_log_write_res] 0-nfs-nfsv3: XID: 18f4dce6, WRITE: NFS: 69(Resource (quota) hard limit exceeded), POSIX: 122(Disk quota exceeded), count: 0, UNSTABLE,wverf: 1381508849
[2013-10-11 16:36:29.392957] W [nfs3.c:2075:nfs3svc_write_cbk] 0-nfs: 19f4dce6: /f.195 => -1 (Disk quota exceeded)
[2013-10-11 16:36:29.393037] W [nfs3-helpers.c:3443:nfs3_log_write_res] 0-nfs-nfsv3: XID: 19f4dce6, WRITE: NFS: 69(Resource (quota) hard limit exceeded), POSIX: 122(Disk quota exceeded), count: 0, UNSTABLE,wverf: 1381508849
[2013-10-11 16:36:29.396236] W [nfs3.c:2075:nfs3svc_write_cbk] 0-nfs: 1af4dce6: /f.195 => -1 (Disk quota exceeded)
[2013-10-11 16:36:29.396273] W [nfs3-helpers.c:3443:nfs3_log_write_res] 0-nfs-nfsv3: XID: 1af4dce6, WRITE: NFS: 69(Resource (quota) hard limit exceeded), POSIX: 122(Disk quota exceeded), count: 0, UNSTABLE,wverf: 1381508849
[2013-10-11 16:36:29.399489] W [nfs3.c:2075:nfs3svc_write_cbk] 0-nfs: 1bf4dce6: /f.195 => -1 (Disk quota exceeded)
[2013-10-11 16:36:29.399525] W [nfs3-helpers.c:3443:nfs3_log_write_res] 0-nfs-nfsv3: XID: 1bf4dce6, WRITE: NFS: 69(Resource (quota) hard limit exceeded), POSIX: 122(Disk quota exceeded), count: 0, UNSTABLE,wverf: 1381508849
[2013-10-11 16:36:29.400156] W [nfs3.c:4952:nfs3svc_commit_cbk] 0-nfs: 1cf4dce6: /f.195 => -1 (Disk quota exceeded)
[2013-10-11 16:36:29.400196] W [nfs3-helpers.c:3504:nfs3_log_commit_res] 0-nfs-nfsv3: XID: 1cf4dce6, COMMIT: NFS: 69(Resource (quota) hard limit exceeded), POSIX: 122(Disk quota exceeded), wverf: 1381508849


Expected results:

we shouldn't be sending many warning message for each single file.

Additional info:
Comment 2 Vivek Agarwal 2013-10-17 03:07:58 EDT
Per discusion with Shanks/Saurabh, removing this from the list
Comment 3 Vivek Agarwal 2013-10-25 04:55:06 EDT
Per discussion with Amar, Expected behaviour as every file which is quota failed needs to be logged.
Comment 4 Saurabh 2013-10-30 02:10:00 EDT
How is this "NOTABUG"?
The issue mentioned is for single file itself having many warning messages
If you wish to have many warning message, rather move it to some other log level.
Re-opening this BZ for further discussion.
Comment 5 Saurabh 2013-10-30 02:11:00 EDT
needinfo based on

https://bugzilla.redhat.com/show_bug.cgi?id=1018170#c4
Comment 6 Vijaikumar Mallikarjuna 2015-01-12 03:45:36 EST
NFS logs warning message logged twice in the FOP callback function. We can remove one log message.
Comment 8 Vivek Agarwal 2015-09-09 06:05:35 EDT
http://review.gluster.org/11936
Comment 11 Manikandan 2015-10-16 02:32:46 EDT
Patch upstream master : http://review.gluster.org/11936
Release-3.7 : http://review.gluster.org/12162
Comment 12 Anil Shah 2015-11-12 05:08:02 EST
Bug verified on build glusterfs-3.7.5-6.
Comment 16 errata-xmlrpc 2016-03-01 00:21:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.