Bug 101819 - eog does not build (require librsvg2-devel)
eog does not build (require librsvg2-devel)
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: eog (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-08-07 07:30 EDT by Michael Redinger
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 16:48:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbuild --rebuild eog-2.2.2-1.src.rpm output (4.64 KB, text/plain)
2003-08-07 07:31 EDT, Michael Redinger
no flags Details

  None (edit)
Description Michael Redinger 2003-08-07 07:30:49 EDT
The Taroon eog-2.2.2-1.src.rpm package does not build correctly
on Taroon (everything install).

The error message says that /usr/lib/pkgconfig/libgsf-1.pc is needed.
So this is really two bugs:

- eog needs libgsf-devel, but this is not included in Taroon (but in Severn)
- there should be a build prereq for libgsf-devel

Attaching the rebuild output.
Comment 1 Michael Redinger 2003-08-07 07:31:24 EDT
Created attachment 93480 [details]
rpmbuild --rebuild eog-2.2.2-1.src.rpm output
Comment 2 Havoc Pennington 2003-08-07 12:53:22 EDT
Taroon isn't intended to be self-hosting; the -devel packages are removed 
to limit ABI support liability (keep customers/ISVs from using libraries 
that we don't want to live with forever).

However the BuildRequires should be there.
Comment 3 Alexander Larsson 2003-08-29 04:55:43 EDT
The issue is really that is should buildreq librsvg2-devel. And librsvg2-devel
should require gsf-devel (that has been fixed now, but used to be broken).
Comment 4 Warren Togami 2004-04-13 16:48:32 EDT
BR intltool libjpeg-devel scrollkeeper gettext
librsvg2-devel has been fixed, so this should be not a problem anymore.

rawhide soon

Note You need to log in before you can comment on or make changes to this bug.