Bug 101825 - gdm does not build
Summary: gdm does not build
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gdm   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-07 13:23 UTC by Michael Redinger
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 21:47:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbuild --rebuild gdm-2.4.1.3-5.src.rpm output (9.56 KB, text/plain)
2003-08-07 13:24 UTC, Michael Redinger
no flags Details

Description Michael Redinger 2003-08-07 13:23:37 UTC
The Taroon gdm-2.4.1.3-5.src.rpm package does not build correctly
on Taroon (everything install):

The error message says that /usr/lib/pkgconfig/libgsf-1.pc is needed.
So this is really two bugs:

- gdm needs libgsf-devel, but this is not included in Taroon (but in Severn)
- there should be a build prereq for libgsf-devel

See also bug #101819

Attaching the rebuild output.

Comment 1 Michael Redinger 2003-08-07 13:24:15 UTC
Created attachment 93481 [details]
rpmbuild --rebuild gdm-2.4.1.3-5.src.rpm output

Comment 2 Havoc Pennington 2003-08-07 16:55:42 UTC
Taroon isn't intended to be self-hosting; the -devel packages are removed 
to limit ABI support liability (keep customers/ISVs from using libraries 
that we don't want to live with forever).

The buildrequires should be there though.

Comment 3 Jeremy Katz 2003-08-20 21:47:01 UTC
Buildrequires is there now


Note You need to log in before you can comment on or make changes to this bug.