Bug 1018308 - GlusterFS installation on CentOS 6.4 fails with "No package rsyslog-mmcount available."
GlusterFS installation on CentOS 6.4 fails with "No package rsyslog-mmcount a...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Bala.FA
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 12:18 EDT by Justin Clift
Modified: 2015-11-22 21:58 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:49:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Clift 2013-10-11 12:18:25 EDT
Description of problem:

  Installation fails for GlusterFS on CentOS 6.4, using RPMs built from
  git source.

  There is a dependency on "rsyslog-mmcount", which doesn't exist for
  CentOS 6.4.

  This seems related to BZ 1000075, which resolves the problem for RHS.

    https://bugzilla.redhat.com/show_bug.cgi?id=1000075


Version-Release number of selected component (if applicable):

  Upstream GlusterFS git master, as of Fri 11th October.


How reproducible:

  Every time.


Steps to Reproduce:
1. Compile GlusterFS on CentOS 6.4 using the official instructions.
2. Attempt to install the rpms.  Failure occurs here.

  $ sudo yum install gluster*
  ...
  Resolving Dependencies
  --> Running transaction check
  ---> Package glusterfs.x86_64 0:3git-1.el6 will be installed
  ---> Package glusterfs-cli.x86_64 0:3git-1.el6 will be installed
  ---> Package glusterfs-debuginfo.x86_64 0:3git-1.el6 will be installed
  ---> Package glusterfs-devel.x86_64 0:3git-1.el6 will be installed
  ---> Package glusterfs-fuse.x86_64 0:3git-1.el6 will be installed
  ---> Package glusterfs-libs.x86_64 0:3git-1.el6 will be installed
  --> Processing Dependency: rsyslog-mmcount for package: glusterfs-libs-3git-1.el6.x86_64
  ---> Package glusterfs-server.x86_64 0:3git-1.el6 will be installed
  --> Finished Dependency Resolution
  Error: Package: glusterfs-libs-3git-1.el6.x86_64 (/glusterfs-libs-3git-1.el6.x86_64)
             Requires: rsyslog-mmcount


Actual results:

  GlusterFS won't install.


Expected results:

  GlusterFS installs.


Additional info:

  The problem may be in glusterfs.spec.in:

  $ git blame glusterfs.spec.in
  ...
  f8e968a4 (Bala.FA                2013-08-22 09:03:38 +0530  200) %if ( 0%{!?_without_syslog:1} )
  e75071a5 (Bala.FA                2013-08-09 17:21:56 +0530  201) %if ( 0%{?fedora} ) || ( 0%{?rhel} && 0%{?rhel} > 6 )
  e75071a5 (Bala.FA                2013-08-09 17:21:56 +0530  202) Requires:         rsyslog-mmjsonparse
  e75071a5 (Bala.FA                2013-08-09 17:21:56 +0530  203) %endif
  e75071a5 (Bala.FA                2013-08-09 17:21:56 +0530  204) %if ( 0%{?rhel} && 0%{?rhel} == 6 )
  e75071a5 (Bala.FA                2013-08-09 17:21:56 +0530  205) Requires:         rsyslog-mmcount
  e75071a5 (Bala.FA                2013-08-09 17:21:56 +0530  206) %endif
  f8e968a4 (Bala.FA                2013-08-22 09:03:38 +0530  207) %endif
Comment 1 Anand Avati 2013-10-18 02:05:44 EDT
REVIEW: http://review.gluster.org/6108 (build: disable logging framework on rhel6) posted (#1) for review on master by Bala FA (barumuga@redhat.com)
Comment 2 Anand Avati 2013-10-18 02:33:55 EDT
REVIEW: http://review.gluster.org/6108 (build: disable logging framework on rhel6) posted (#2) for review on master by Bala FA (barumuga@redhat.com)
Comment 3 Anand Avati 2013-10-18 05:19:34 EDT
REVIEW: http://review.gluster.org/6108 (build: disable logging framework on rhel6) posted (#3) for review on master by Bala FA (barumuga@redhat.com)
Comment 4 Anand Avati 2013-10-18 11:30:14 EDT
COMMIT: http://review.gluster.org/6108 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 9228618f9d566d1af29b6a4946426df09b7737bc
Author: Bala.FA <barumuga@redhat.com>
Date:   Fri Oct 18 11:06:59 2013 +0530

    build: disable logging framework on rhel6
    
    As rsyslog-mmcount is not yet available in rhel6 variant, this patch
    disables logging framework on rhel6 and its dependency
    
    BUG: 1018308
    Change-Id: I6b7c04640f8d38055e00c697d1017c7a530463d0
    Signed-off-by: Bala.FA <barumuga@redhat.com>
    Reviewed-on: http://review.gluster.org/6108
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Niels de Vos 2014-04-17 07:49:39 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.