Bug 1018706 - ha-agent service can't start because failure to start sanlock
ha-agent service can't start because failure to start sanlock
Status: CLOSED DUPLICATE of bug 1013563
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Doron Fediuck
yeylon@redhat.com
sla
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 04:49 EDT by Leonid Natapov
Modified: 2016-04-18 03:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 05:19:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Natapov 2013-10-14 04:49:04 EDT
ha-agent service can't start because failure to start sanlock because of lack of permissions.
----------------
MainThread::DEBUG::2013-10-13 18:01:44,539::hosted_engine::322::HostedEngine::(_initialize_vdsm) stderr: 
MainThread::INFO::2013-10-13 18:01:44,539::hosted_engine::324::HostedEngine::(_initialize_vdsm) Successfully verified that VDSM is attached to storage
MainThread::DEBUG::2013-10-13 18:01:44,541::hosted_engine::333::HostedEngine::(_initialize_vdsm) Path to storage domain is /rhev/data-center/mnt/orion.qa.lab.tlv.redhat.com:_export_hosted__engine1/ef4a31eb-688f-4f19-af9f-6a3e0bf82ebf
MainThread::DEBUG::2013-10-13 18:01:44,542::hosted_engine::336::HostedEngine::(_cond_start_service) Checking sanlock status
MainThread::ERROR::2013-10-13 18:02:09,594::hosted_engine::344::HostedEngine::(_cond_start_service) Starting sanlock

MainThread::WARNING::2013-10-13 18:02:15,025::hosted_engine::247::HostedEngine::(start_monitoring) Error while monitoring engine: Could not start sanlock: 

Sorry, user vdsm is not allowed to execute '/sbin/service sanlock start' as root on purple-vds3.qa.lab.tlv.redhat.com.

MainThread::WARNING::2013-10-13 18:02:15,026::hosted_engine::250::HostedEngine::(start_monitoring) Unexpected error
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/agent/hosted_engine.py", line 236, in start_monitoring
    self._initialize_sanlock()
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/agent/hosted_engine.py", line 369, in _initialize_sanlock
    self._cond_start_service('sanlock')
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/agent/hosted_engine.py", line 353, in _cond_start_service
    .format(service_name, res[1]))
Exception: Could not start sanlock: Sorry, user vdsm is not allowed to execute '/sbin/service sanlock start' as root on purple-vds3.qa.lab.tlv.redhat.com.

MainThread::ERROR::2013-10-13 18:02:15,026::hosted_engine::264::HostedEngine::(start_monitoring) Shutting down the agent because of 3 failures in a row!
MainThread::DEBUG::2013-10-13 18:02:15,026::hosted_engine::270::HostedEngine::(start_monitoring) Disconnecting from ha-broker
MainThread::INFO::2013-10-13 18:02:15,027::brokerlink::54::BrokerLink::(disconnect) Closing connection to ha-broker
-------------------
vdsm-4.13.0-13.gitc08fbb6.el6_4.x86_64
ovirt-hosted-engine-setup-1.0.0-0.5.2.beta1.local.el6.noarch
ovirt-hosted-engine-ha-0.1.0-0.2.2.beta1.local.el6.noarch
Comment 1 Sandro Bonazzola 2013-10-14 05:19:50 EDT
different error output, but the same issue of bug #1013563.

*** This bug has been marked as a duplicate of bug 1013563 ***

Note You need to log in before you can comment on or make changes to this bug.