Bug 1018915 - Brightness applet not clickable with mouse
Brightness applet not clickable with mouse
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-power-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
: 965633 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 12:52 EDT by Andrew Lofthouse
Modified: 2013-11-10 02:25 EST (History)
5 users (show)

See Also:
Fixed In Version: mate-power-manager-1.6.3-0.2.gitbc54d96.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 23:28:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (1.95 KB, patch)
2013-10-14 12:52 EDT, Andrew Lofthouse
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 612399 None None None Never

  None (edit)
Description Andrew Lofthouse 2013-10-14 12:52:21 EDT
Created attachment 812117 [details]
Patch

Description of problem: The brightness applet on the MATE panel will not allow mouse clicks (the applet disappears when trying to click).  This is an old bug of gnome 2, reported at https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/535097 and upstream at https://bugzilla.gnome.org/show_bug.cgi?id=612399 (also reported against an old Fedora release at https://bugzilla.redhat.com/show_bug.cgi?id=610886).  The attached patch comes from the upstream bug report and seems to work on my installation of MATE on Fedora 19.


Version-Release number of selected component (if applicable): mate-power-manager-1.6.2-4


How reproducible:
Always

Steps to Reproduce:
1. Add brightness applet to MATE panel
2. Try to change brightness by clicking the applet to change settings

Actual results:
Applet brightness setting slider disappears.

Expected results:
Applet brightness setting slider changes with mouse clicking/movement
Comment 1 Wolfgang Ulbrich 2013-10-14 13:21:30 EDT
Thank you, i will test your fix.
The prob is that left and right mouse clicks are reversed. See
https://bugzilla.redhat.com/show_bug.cgi?id=965633#c3
Comment 2 Wolfgang Ulbrich 2013-10-14 13:22:25 EDT
*** Bug 965633 has been marked as a duplicate of this bug. ***
Comment 3 Wolfgang Ulbrich 2013-10-14 17:18:16 EDT
Fix is send to upstream.
https://github.com/mate-desktop/mate-power-manager/pull/82
Comment 4 Fedora Update System 2013-10-15 12:34:25 EDT
mate-power-manager-1.6.3-0.2.gitbc54d96.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mate-power-manager-1.6.3-0.2.gitbc54d96.fc20
Comment 5 Fedora Update System 2013-10-16 04:58:50 EDT
mate-power-manager-1.6.3-0.2.gitbc54d96.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-power-manager-1.6.3-0.2.gitbc54d96.fc18
Comment 6 Fedora Update System 2013-10-16 04:59:09 EDT
mate-power-manager-1.6.3-0.2.gitbc54d96.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-power-manager-1.6.3-0.2.gitbc54d96.fc19
Comment 7 Fedora Update System 2013-10-18 15:34:02 EDT
Package mate-power-manager-1.6.3-0.2.gitbc54d96.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-power-manager-1.6.3-0.2.gitbc54d96.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19242/mate-power-manager-1.6.3-0.2.gitbc54d96.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-10-22 23:28:09 EDT
mate-power-manager-1.6.3-0.2.gitbc54d96.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-10-22 23:39:11 EDT
mate-power-manager-1.6.3-0.2.gitbc54d96.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-11-10 02:25:44 EST
mate-power-manager-1.6.3-0.2.gitbc54d96.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.