Bug 1019160 - Add operation result into post-install logs
Add operation result into post-install logs
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER6
: EAP 6.2.0
Assigned To: Thomas Hauser
Petr Kremensky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 04:47 EDT by Petr Kremensky
Modified: 2017-10-09 20:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:55:44 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-15 04:47:26 EDT
Description of problem:
 It would be nice to have results of all CLI operations performed during post-install configuration in post-install logs. This way user can immediately identify the reason why post-install configuration failed without manually reproducing all CLI operations that installer have made.

Version-Release number of selected component (if applicable):
 EAP 6.2.0. ER5

How reproducible:
 Always

Steps to Reproduce:
 1. Use BZ1019156 steps to fail the installation
 2. observe post-install logs inside $JBOSS_HOME/postinstall-logs


Actual results:
 No CLI operation results inside.

Expected results:
 Result of each command is stored inside logs.
Comment 1 Francisco Canas 2013-10-15 11:45:38 EDT
Some big changes to the logging mechanisms:
- All CLI operations are now set to verbose and their results logged 
- The postinstall-logs folder is removed. Instead, there is one file at $INSTALL_PATH/InstallationLog.txt that contains all installation result logs (including the CLI operations)

See this commit, and other related commits for details:
http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=d6dadd5f45435e301351f83fc09c1d1cacd3fbdd
Comment 2 Petr Kremensky 2013-10-18 05:42:43 EDT
All possible information (also CLI commnad outputs) can be now found inside $INSTALL_PATH/InstallationLog.txt file. Good job!

Verified on EAP 6.2.0.ER6 installer.

Note You need to log in before you can comment on or make changes to this bug.