Bug 101917 - up2date not removing packages that are already installed
up2date not removing packages that are already installed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: up2date (Show other bugs)
beta1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-08-07 20:38 EDT by Justin Churchey
Modified: 2007-04-18 12:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-15 21:50:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Churchey 2003-08-07 20:38:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When trying to run up2date, I get the following two updates:

aspell 0.50.3-15
xemacs-el 21.4.13-4

However, the Version and Old Version fields are identical.  When attempting to
update I get the following dialog box:

Test install failed because of package conflicts:
package aspell-0.50.3-15 is already installed
package xemacs-el-21.4.13-4 is already installed

If the packages are already installed, I do not see why they continue to come up
as packages to be updated.  They should not be on there at all.  I was wondering
if there was a problem w/ up2date reading the RPM tables .

Version-Release number of selected component (if applicable):
up2date-3.1.46-2

How reproducible:
Always

Steps to Reproduce:
1.Run up2date
2.Click Forward
3.Select the packages to be installed
4.Click Foward
    

Actual Results:  up2date reports that the packages are already installed even
though they are listed as out-of-date packages.

Expected Results:  up2date should not displayed packages that are already
installed on the system.

Additional info:
Comment 1 Adrian Likins 2003-09-15 17:31:43 EDT
is this still a problem with current code?

3.9 25 or higher should all be fine

There were some bugs with early version in the beta
miscalcuating needed packages. 

Comment 2 Justin Churchey 2003-09-15 19:08:31 EDT
Not sure if that is the problem right now.  My system has been down for
maintainance, and I have not been able to update any of the packages since I
installed the Beta.  

Note You need to log in before you can comment on or make changes to this bug.