Bug 1019175 - Subsections of 9.2. "Deploy with the Management Console" are outdated due to update of Management Console
Subsections of 9.2. "Deploy with the Management Console" are outdated due to ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: post-GA
: EAP 6.4.3
Assigned To: Priyanka Nag
Pavel Jelinek
: Documentation
: 1087359 1087376 (view as bug list)
Depends On:
Blocks: 950412
  Show dependency treegraph
 
Reported: 2013-10-15 05:09 EDT by Jakub Cechacek
Modified: 2015-10-20 08:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 08:51:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Cechacek 2013-10-15 05:09:20 EDT
Management console in EAP 6.2.0 was updated to version 2.0. The new console introduced the whole redesign of the UI. Consequently subsection of chapter  9.2. "Deploy with the Management Console" should be updated to reflect these changes - update all screen shots and text descriptions.
Comment 1 Nichola Moore 2014-04-23 21:38:31 EDT
The screenshots were removed for EAP 6.2-ER7. I have updated the processes to reflect the current UI.

Changed topic 3764, revision 633372.
Comment 2 Nichola Moore 2014-04-23 21:51:26 EDT
*** Bug 1087359 has been marked as a duplicate of this bug. ***
Comment 3 Nichola Moore 2014-04-23 21:56:25 EDT
*** Bug 1087376 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Cechacek 2014-05-12 04:56:01 EDT
As stated elsewhere. The removal of screenshots in 6.2-ER7 seems like a temporary release hot fix. I strongly believe that screenshots are providing vital information and should be incorporated as much as possible when describing a GUI related procedure. 

I suggest to update the doc with current screenshot.
Comment 6 Jakub Cechacek 2015-01-15 05:57:56 EST
Issue is still valid in latest doc

1) due to another update the text needs to be rewritten again -- deployments now have their own separate top level tab (and thus are no longer located under runtime)

2) Screenshots are still missing
Comment 10 Pavel Jelinek 2015-06-19 09:40:38 EDT
I have checked the chapter "10.2. Deploy with the Management Console" in Administration and Configuration guide revision 6.4.0-30.

The first part of chapter was successfuly updated. 

The reason for rejecting this bugzilla is that subchapters "10.2.3. Disable a Deployed Application Using the Management Console" and "10.2.4. Undeploy an Application Using the Management Console" were not updated at all. Both these subchapters still describe outdated navigation with deployments under Runtime tab and are still lacking screenshots.
Comment 12 Nidhi 2015-07-03 02:07:48 EDT
http://docbuilder.usersys.redhat.com/23087/#Manage_Application_Deployment_in_the_Management_Console

# "... applications are deployed to your server or server groups, and you can disable or delete applications from the content repository as ..." - we may add that one could also 'enable' applications.

http://docbuilder.usersys.redhat.com/23087/#Deploy_an_Application_Using_the_Management_Console1
 - Procedure 10.1. Enable a Deployed Application using the Management Console
# Step 2 isn't really a step. Perhaps we could merge it with step 1.

 - Enable an application in a managed domain
# Click confirm to confirm that the application will be enabled on the server instance. - Change 'confirm' to 'Confirm'

## Step 2 needs to be corrected in all the three procedures.

I'm not sure if this is the best way to share review comments. Please let me know if you need any clarifications. :)
Comment 15 Pavel Jelinek 2015-07-29 09:03:00 EDT
Verify that for Admin Guide revision 6.4.0-35 the sub-chapters 'Disable a Deployed Application Using the Management Console' and 'Undeploy an Application Using the Management Console' have updated both text and screenshots.
But there are some smaller issues yet:

In sub-chapter '10.2.2. Enable a Deployed Application Using the Management Console' 
in paragraph 'Result' there is sentence 
'The application is DEPLOYED on the relevant server or server group.' 
but should be 
'The application is ENABLED on the relevant server or server group.'

In sub-chapter '10.2.3. Disable a Deployed Application Using the Management Console' 
in paragraph 'Disable a deployed application on a managed domain' in step b there is sentence 
'Select the name of the SERVER in the Server Group table to undeploy an application from.'
but should be 
'Select the name of the SERVER GROUP in the Server Group table to undeploy an application from. '
in paragraph 'Result' there is sentence 
'The application is UNDEPLOYED from the relevant server or server group. ' 
but should be 
'The application is DISABLED from the relevant server or server group. '

In sub-chapter '10.2.4. Undeploy an Application Using the Management Console' 
in paragraph 'Undeploy a deployed application from a managed domain' step b there is sentence 
'Select the name of the SERVER in the Server Group table to undeploy an application from.'
but should be 
'Select the name of the SERVER GROUP in the Server Group table to undeploy an application from. '
Comment 18 Jan Kasik 2015-08-25 04:10:12 EDT
Verified for Administration and Configuration Guide, revision 6.4.0-36.

Note You need to log in before you can comment on or make changes to this bug.