This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1019184 - [zh_CN][pt_BR][ko_KR][es_ES][it_IT][fr_FR][RHSM Firstboot] Wrong page strings in 'Choose Service' page.
[zh_CN][pt_BR][ko_KR][es_ES][it_IT][fr_FR][RHSM Firstboot] Wrong page strings...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.5
x86_64 Linux
high Severity urgent
: rc
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
: Reopened, Translation
Depends On:
Blocks: 1056252 rhsm-rhel66
  Show dependency treegraph
 
Reported: 2013-10-15 05:19 EDT by Lijun Li
Modified: 2014-10-14 03:28 EDT (History)
12 users (show)

See Also:
Fixed In Version: rhn-client-tools-1.0.0.1-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:28:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Error translation in 'Choose Service' page (157.52 KB, image/png)
2013-10-15 05:25 EDT, Lijun Li
no flags Details
[zh_CN][pt_BR][ko_KR] Wrong page strings in 'Choose Service' page (107.32 KB, image/png)
2014-09-28 05:07 EDT, Lijun Li
no flags Details
[es_ES][it_IT][fr_FR] Wrong page strings in 'Choose Service' page (94.47 KB, image/png)
2014-09-30 04:39 EDT, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2013-10-15 05:19:22 EDT
Description of problem:
[zh_CN][RHSM Firstboot] Error translation in 'Choose Service' page.

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-1.9.9-1.el6.x86_64

How reproducible:
100%


Steps to Reproduce:
1. Install latest rhel6.5 and run firstboot --reconfig in terminal.
2. On 'Set Up Software Updates' page, select Yes and Forward.
3. Click 'Proxy Setup' button on 'Choose Services' page.

Actual results:
[zh_CN][RHSM Firstboot] Error translation in 'Choose Service' page.

Expected results:
They should be translated based on the English string and layout.

Additional info:
Comment 1 Lijun Li 2013-10-15 05:25:18 EDT
Created attachment 812397 [details]
Error translation in 'Choose Service' page
Comment 3 John Sefler 2013-10-16 08:55:49 EDT
The translations on the Choose Service panel in firstboot come from the rhn-client-tools package, not subscription-manager.

[root@jsefler-6 ~]# rpm -q --whatprovides /usr/share/locale/zh_CN/LC_MESSAGES/rhn-client-tools.mo
rhn-client-tools-1.0.0.1-13.el6.noarch


[root@jsefler-6 ~]# msgunfmt /usr/share/locale/zh_CN/LC_MESSAGES/rhn-client-tools.mo | egrep -A1 "Choose Service"
msgid "Choose Service"
msgstr "选择服务器"

[root@jsefler-6 ~]# msgunfmt /usr/share/locale/zh_CN/LC_MESSAGES/rhn-client-tools.mo | egrep -A1 "Proxy Configuration"
msgid "Proxy Configuration"
msgstr "(_P)Proxy 位置:"

[root@jsefler-6 ~]# msgunfmt /usr/share/locale/zh_CN/LC_MESSAGES/rhn-client-tools.mo | egrep -A1 -B1 \"Location:\"

msgid "Location:"
msgstr "(_P)Proxy 位置:"
--
msgctxt "yes"
msgid "Location:"
msgstr "位置:"


^^ Looks like there are two msgid/translations for the same "Location:" key.  That seems wrong. I don't know what msgctxt means, but according to the screenshot attached, it looks like the translation being employed for "Location:" is not the one wanted.
Comment 4 RHEL Product and Program Management 2013-10-19 09:24:40 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Tomas Lestach 2013-10-23 07:41:50 EDT
Similar to Bug 1019146 this issue has been fixed within Bug 912984, so it will be part of rhel6.5.

Closing as DUPLICATE of Bug 1019146.

*** This bug has been marked as a duplicate of bug 1019146 ***
Comment 6 Lijun Li 2013-10-29 07:27:27 EDT
Moving to ASSIGNED as it's not the same issue with Bug 912984 , please see Comment 1 and Comment 3, also refer to the attached screenshot.


Verified it's NOT fixed on build rhn-client-tools-1.0.0.1-16.

The same issue also reproduced on ko_KR, pt_BR, ru_RU locales.

Thanks,
Robert
Comment 10 Stephen Herr 2014-07-25 17:22:26 EDT
Those pages (and associated translations) are definitely provided by rhn-client-tools, I'm not sure why this was re-assigned to subscription-manager.
Comment 12 Adrian Likins 2014-07-25 18:02:57 EDT
I think this is just errors in the rhn-client-tools zh_CN.po

The translations for

#: ../data/rh_register.glade.h:130
msgid "_Proxy Location:"
msgstr "(_P)Proxy 位置:"

#: ../data/rh_register.glade.h:132
msgid "proxy location"
msgstr "proxy 位置"

#: ../data/rh_register.glade.h:21
msgctxt "yes"
msgid "Location:"
msgstr "位置:"

#: ../data/rh_register.glade.h:22
msgid "Location:"
msgstr "(_P)Proxy 位置:"

#: ../data/rh_register.glade.h:134
msgid "Use Authentication with HTTP Proxy"
msgstr "使用 HTTP Proxy 验证"

#: ../data/rh_register.glade.h:135
msgid "Proxy _Username:"
msgstr "Proxy 用户名(_U):"

#: ../data/rh_register.glade.h:136
msgid "Proxy P_assword:"
msgstr "Proxy 密码(_a):"

#: ../data/rh_register.glade.h:125
msgid "Proxy Configuration"
msgstr "(_P)Proxy 位置:"

Those are not translating 'Proxy' as for "RHN Proxy", but those cases are referring to http proxies. The "Location:" and "Proxy Configuration" msgids
are also specifically for labels  (the proxy config dialog window name, and the label beside the proxy url entry box), so the accelerator key mappings (_P) don't make sense and are not being escaped on display.
Comment 14 Glaucia Cintra 2014-08-18 20:06:33 EDT
pt-BR fixed and resubmitted.
Comment 16 Michael Mráka 2014-08-26 05:54:50 EDT
Translation updated in satellite git: 

commit 8dc46426e3c8b04278e884e435f35cabbf777a93
    1019184 - fixed translations  ko, pt_br, ru and zh_CN
Comment 20 Lijun Li 2014-09-28 04:57:25 EDT
Reproduced on rhn-client-tools-1.0.0.1-18 , still the wrong page strings in the  'Choose Service' page for zh_CN, pt_BR, ko_KR.

See the attached screen-shot.
Comment 21 Lijun Li 2014-09-28 05:07:03 EDT
Created attachment 941968 [details]
[zh_CN][pt_BR][ko_KR] Wrong page strings in 'Choose Service' page
Comment 22 Michael Mráka 2014-09-29 07:05:39 EDT
Translations updated by
commit 3ea4bead7edfb8eb18ed0143c1f6a4709462c313
    1019184 - minor fixes in ko, pt_BR and zh_CN translations
Comment 24 Lijun Li 2014-09-30 04:38:49 EDT
also reproduced on es_ES, it_IT, fr_FR.
Comment 25 Lijun Li 2014-09-30 04:39:17 EDT
Created attachment 942629 [details]
[es_ES][it_IT][fr_FR] Wrong page strings in 'Choose Service' page
Comment 32 errata-xmlrpc 2014-10-14 03:28:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1537.html

Note You need to log in before you can comment on or make changes to this bug.