Bug 1019329 - traceback on No such file or directory: '/usr/lib/python2.7/site-packages/kobo/client/default.conf'
traceback on No such file or directory: '/usr/lib/python2.7/site-packages/kob...
Status: CLOSED DUPLICATE of bug 990016
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.11
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 09:47 EDT by Karel Volný
Modified: 2014-08-12 00:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 10:07:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-10-15 09:47:53 EDT
Description of problem:
Trying to submit a test, bkr command fails with traceback, see below.

Version-Release number of selected component (if applicable):
beaker-client-0.14.1-1.fc18.noarch

How reproducible:
always

Steps to Reproduce:
1. check out some test, re-tag it
2. make bkradd

Actual results:
Traceback (most recent call last):
  File "/usr/bin/bkr", line 9, in <module>
    load_entry_point('bkr.client==0.14.1', 'console_scripts', 'bkr')()
  File "/usr/lib/python2.7/site-packages/bkr/client/main.py", line 50, in main
    return cmd.run(*cmd_args, **cmd_opts.__dict__)
  File "/usr/lib/python2.7/site-packages/bkr/client/commands/cmd_task_add.py", line 68, in run
    self.set_hub(**kwargs)
  File "/usr/lib/python2.7/site-packages/bkr/client/__init__.py", line 34, in set_hub
    self.container.set_hub(username, password)
  File "/usr/lib/python2.7/site-packages/kobo/client/__init__.py", line 113, in set_hub
    self.hub = HubProxy(conf=self.conf)
  File "/usr/lib/python2.7/site-packages/kobo/client/__init__.py", line 142, in __init__
    self._conf.load_from_file(default_config)
  File "/usr/lib/python2.7/site-packages/kobo/conf.py", line 117, in load_from_file
    fo = open(file_name, "r")
IOError: [Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/kobo/client/default.conf'
Exception AttributeError: AttributeError("'HubProxy' object has no attribute '_transport'",) in <bound method HubProxy.__del__ of <kobo.client.HubProxy object at 0x7fee052f77d0>> ignored
make: *** [bkradd] Error 1


Expected results:
no such error

Additional info:
I have kobo-client-0.4.0-1.fc19.noarch installed and it does not provide the file, seems it got removed since kobo-client-0.3.8-1.fc19.noarch ... I'm no Python expert, seems more like a kobo problem to me, but it is bkr which fails for me, so reporting for Beaker, feel free to reassign ...
Comment 2 Karel Volný 2013-10-15 10:07:10 EDT
stupid search, sorry for the noise

*** This bug has been marked as a duplicate of bug 990016 ***
Comment 3 Nick Coghlan 2013-10-15 20:57:24 EDT
I was about to suggest trying "yum install --enablerepo updates-testing" to install kobo-client-0.4.1, but I see you already found that: https://admin.fedoraproject.org/updates/kobo-0.4.1-1.fc19 :)

Note You need to log in before you can comment on or make changes to this bug.