Bug 990016 - "make bkradd" is failing as kobo-client does not provide default.conf
"make bkradd" is failing as kobo-client does not provide default.conf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kobo (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Mach
Fedora Extras Quality Assurance
: Reopened
: 1019329 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 05:11 EDT by Branislav Blaškovič
Modified: 2014-01-18 13:20 EST (History)
8 users (show)

See Also:
Fixed In Version: kobo-0.4.2-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 20:57:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Branislav Blaškovič 2013-07-30 05:11:50 EDT
Description of problem:
  kobo-client does not provide file '/usr/lib/python2.7/site-packages/kobo/client/default.conf' in version 'kobo-client-0.3.8-1.fc19'.

Version-Release number of selected component (if applicable):
  kobo-client-0.4.0-1.fc19

[root@bblaskov ~]# rpm -q kobo-client
kobo-client-0.3.8-1.fc19.noarch
[root@bblaskov ~]# rpm -ql kobo-client | grep default.conf
/usr/lib/python2.7/site-packages/kobo/client/default.conf
[root@bblaskov ~]# yum update kobo-client
...
[root@bblaskov ~]# rpm -q kobo-client
kobo-client-0.4.0-1.fc19.noarch
[root@bblaskov ~]# rpm -ql kobo-client | grep default.conf
[root@bblaskov ~]#
Comment 1 Lalatendu Mohanty 2013-09-30 13:36:41 EDT
I am encountering an issue because of this.

"make bkradd" commands are failing because of this with below error

Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.G5xmqx
+ umask 022
+ cd /mnt/testarea/rhts-build-ib8JJESE/rpm-build
+ cd rhs-tests-rhs-tests-beaker-rhs-gluster-qe-libs-dev-lmohanty-1.38.001
+ '[' /home/lmohanty/rpmbuild/BUILDROOT/rhs-tests-rhs-tests-beaker-rhs-gluster-qe-libs-dev-lmohanty-1.38.001-0.x86_64 '!=' / ']'
+ '[' -d /home/lmohanty/rpmbuild/BUILDROOT/rhs-tests-rhs-tests-beaker-rhs-gluster-qe-libs-dev-lmohanty-1.38.001-0.x86_64 ']'
+ rm -rf /home/lmohanty/rpmbuild/BUILDROOT/rhs-tests-rhs-tests-beaker-rhs-gluster-qe-libs-dev-lmohanty-1.38.001-0.x86_64
+ exit 0
/mnt/testarea/rhts-build-ib8JJESE/install ~/work-code/rhs-tests/beaker/rhs/gluster-qe-libs
Traceback (most recent call last):
  File "/usr/bin/bkr", line 9, in <module>
    load_entry_point('bkr.client==0.14.1', 'console_scripts', 'bkr')()
  File "/usr/lib/python2.7/site-packages/bkr/client/main.py", line 50, in main
    return cmd.run(*cmd_args, **cmd_opts.__dict__)
  File "/usr/lib/python2.7/site-packages/bkr/client/commands/cmd_task_add.py", line 68, in run
    self.set_hub(**kwargs)
  File "/usr/lib/python2.7/site-packages/bkr/client/__init__.py", line 34, in set_hub
    self.container.set_hub(username, password)
  File "/usr/lib/python2.7/site-packages/kobo/client/__init__.py", line 113, in set_hub
    self.hub = HubProxy(conf=self.conf)
  File "/usr/lib/python2.7/site-packages/kobo/client/__init__.py", line 142, in __init__
    self._conf.load_from_file(default_config)
  File "/usr/lib/python2.7/site-packages/kobo/conf.py", line 117, in load_from_file
    fo = open(file_name, "r")
IOError: [Errno 2] No such file or directory: '/usr/lib/python2.7/site-packages/kobo/client/default.conf'
Exception AttributeError: AttributeError("'HubProxy' object has no attribute '_transport'",) in <bound method HubProxy.__del__ of <kobo.client.HubProxy object at 0x7f194dbd07d0>> ignored
make: *** [bkradd] Error 1
rm testinfo.desc
Comment 2 Lalatendu Mohanty 2013-09-30 13:46:49 EDT
"make bkradd" was working for me but when I did  a yum update and yum install ipython on my f19 machine , the issue started showing up
Comment 4 Dan Callaghan 2013-10-04 03:22:40 EDT

*** This bug has been marked as a duplicate of bug 997735 ***
Comment 5 Fedora Update System 2013-10-14 04:33:06 EDT
kobo-0.4.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/kobo-0.4.1-1.el6
Comment 6 Fedora Update System 2013-10-14 04:33:22 EDT
kobo-0.4.1-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/kobo-0.4.1-1.el5
Comment 7 Fedora Update System 2013-10-14 04:33:38 EDT
kobo-0.4.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kobo-0.4.1-1.fc20
Comment 8 Fedora Update System 2013-10-14 04:33:55 EDT
kobo-0.4.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kobo-0.4.1-1.fc19
Comment 9 Fedora Update System 2013-10-14 04:34:11 EDT
kobo-0.4.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kobo-0.4.1-1.fc18
Comment 10 Fedora Update System 2013-10-14 12:08:51 EDT
Package kobo-0.4.1-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing kobo-0.4.1-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11836/kobo-0.4.1-1.el5
then log in and leave karma (feedback).
Comment 11 Karel Volný 2013-10-15 10:07:10 EDT
*** Bug 1019329 has been marked as a duplicate of this bug. ***
Comment 12 Ben Turner 2013-10-21 11:10:04 EDT
I tested with:

http://koji.fedoraproject.org/koji/buildinfo?buildID=471159

I can confirm that this package fixed the issue.
Comment 13 Fedora Update System 2013-10-25 20:57:58 EDT
kobo-0.4.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Dr. David Alan Gilbert 2013-12-10 06:18:13 EST
Note that 0.4.1-1 isn't in 'stable' in fc20 yet
Comment 15 Fedora Update System 2013-12-17 08:43:20 EST
kobo-0.4.2-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/kobo-0.4.2-1.el5
Comment 16 Fedora Update System 2013-12-17 08:43:47 EST
kobo-0.4.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kobo-0.4.2-1.fc19
Comment 17 Fedora Update System 2013-12-17 08:44:06 EST
kobo-0.4.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/kobo-0.4.2-1.el6
Comment 18 Fedora Update System 2013-12-17 08:44:22 EST
kobo-0.4.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kobo-0.4.2-1.fc20
Comment 19 Fedora Update System 2013-12-17 08:44:47 EST
kobo-0.4.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kobo-0.4.2-1.fc18
Comment 20 Fedora Update System 2013-12-27 21:04:55 EST
kobo-0.4.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2013-12-27 21:06:38 EST
kobo-0.4.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2013-12-27 21:10:19 EST
kobo-0.4.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2014-01-18 13:20:06 EST
kobo-0.4.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2014-01-18 13:20:57 EST
kobo-0.4.2-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.