Bug 1019509 - Bluetooth headset does not offer HSP/HFP modus
Bluetooth headset does not offer HSP/HFP modus
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
20
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Don Zickus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 18:01 EDT by Jan-Michael Brummer
Modified: 2015-06-29 08:38 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 08:38:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1045548 None None None Never

  None (edit)
Description Jan-Michael Brummer 2013-10-15 18:01:30 EDT
Description of problem:
My Samsung HM1700 headset currently only offers A2DP as bluetooth profile, no HFP/HSP profile. That means of course that i'm only able to hear but not record any sound. This makes phone application useless.

Version-Release number of selected component (if applicable):
Version    : 5.9
Release    : 4.fc20

How reproducible:
Always

Steps to Reproduce:
1. Pair headset
2. Show supported profiles in GNOME control center or using pacmd in command line.
3.

Actual results:
Lists only A2DP profile.

Expected results:
Lists A2DP profile *and* HFP/HSP.

Additional info:
    index: 1
	name: <bluez_card.50_A4_C8_AA_81_92>
	driver: <module-bluez5-device.c>
	owner module: 25
	properties:
		device.description = "HM1700"
		device.string = "50:A4:C8:AA:81:92"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_50_A4_C8_AA_81_92"
		bluez.class = "0x240404"
		bluez.alias = "HM1700"
		device.icon_name = "audio-headset-bluetooth"
		device.intended_roles = "phone"
	profiles:
		a2dp: High Fidelity Playback (A2DP Sink) (priority 10, available: unknown)
		off: Aus (priority 0, available: yes)
	active profile: <a2dp>
	sinks:
		bluez_sink.50_A4_C8_AA_81_92/#2: HM1700
	sources:
		bluez_sink.50_A4_C8_AA_81_92.monitor/#3: Monitor of HM1700
	ports:
		headset-output: Headset (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
		headset-input: Headset (priority 0, latency offset 0 usec, available: no)
			properties:
Comment 1 Kevin R. Page 2014-02-09 13:43:13 EST
Also for Logitech Bluetooth headphone on F20 -- I can use it in A2DP mode to listen, but no option to use in headset mode (i.e. no mic).

This is a regression from previous Fedora versions, where this headset worked fine.

bluez-5.14-1.fc20.x86_64
alsa-lib-1.0.27.2-2.fc20.i686
Comment 2 Andrew Dingman 2014-10-17 14:38:23 EDT
Reproduced on F20 with bluez-5.18-1.fc20.x86_64 using a Jawbone Era and a Rocketfish RF-MAB2. Both worked in F19.
Comment 3 Jonathan 2014-10-22 04:02:43 EDT
Verified F20.
kernel     3.16.4-200.fc20.x86_64
bluez      5.18-1.fc20
pulseaudio 5.0-7.fc20
Comment 4 Eric Work 2014-12-06 14:12:06 EST
Same here.  It use to work in a previous Fedora release.  Just tried it now after maybe a year.  A2DP works fine, but no option for HSP/HFP.  Also tried pavucontrol.

kernel-3.17.4-200.fc20.x86_64
bluez-5.18-2.fc20.x86_64
pulseaudio-5.0-7.fc20.x86_64

ASUS USB-BT400
Plantronics Pulsar 590A
Comment 5 Eric Work 2014-12-06 14:46:51 EST
Unfortunately... this is expected.

http://www.bluez.org/release-of-bluez-5-0/

Bluez 5.0 removed support for HSP/HFP and expects a 3rd party plugin to support it.
Comment 6 Jan-Michael Brummer 2014-12-07 05:14:24 EST
Pulseaudio finally has support for HSP, works fine with F21 and backported with F20. See #1045548
Comment 7 Fedora End Of Life 2015-05-29 05:34:51 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2015-06-29 08:38:58 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.