Bug 1045548 - HSP/HFP Profile not available for Bluetooth headset in Fedora 20, was available in Fedora 19
Summary: HSP/HFP Profile not available for Bluetooth headset in Fedora 20, was availab...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Depends On: ofono
Blocks: 905283
TreeView+ depends on / blocked
 
Reported: 2013-12-20 17:17 UTC by Jonathan Kamens
Modified: 2017-04-13 00:25 UTC (History)
35 users (show)

Fixed In Version: pulseaudio-5.0-25.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-22 00:45:57 UTC


Attachments (Terms of Use)
Backport HSP patches from pulseaudio upstream (98.05 KB, patch)
2014-10-22 02:04 UTC, Mauro Carvalho Chehab
no flags Details | Diff
pulseaudio -vvvv log (234.59 KB, text/plain)
2014-10-23 11:44 UTC, Brian J. Murrell
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 73325 None None None Never

Internal Links: 1019509

Description Jonathan Kamens 2013-12-20 17:17:30 UTC
In Fedora 19, when I connected my Bluetooth headset, the sound settings allowed me to choose between the A2DP Sink profile (sink only) and the HSP/HFP Telephony profile (mono sink + mic source).

In Fedora 20, the HSP/HFP Telephony profile is no longer offered as an option in the sound settings.

I.e., my headset is pretty much useless. Awesome.

Comment 1 Carl van Tonder 2014-01-03 16:32:26 UTC
Exactly the same issue for me (was working perfectly until the F20 update).

My not-very-fancy adapter:

    carl@hostname:[~]$ sudo lsusb | grep Bluetooth
    Bus 001 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

and also-not-very-fancy headset:

    carl@hostname:[~]$ sudo hcitool info 00:18:91:38:E0:E7
    Requesting information ...
    	BD Address:  00:18:91:38:E0:E7
    	OUI Company: Zhongshan General K-mate Electronics Co., Ltd (00-18-91)
    	Device Name: BTHS600
    	LMP Version: 2.1 (0x4) LMP Subversion: 0x173a
    	Manufacturer: Cambridge Silicon Radio (10)

`bluetoothctl` seems to see all the expected profiles:

    carl@hostname:[~/P/BestFootForward]$ bluetoothctl 
    [NEW] Controller 00:15:83:3D:0A:57 hostname-0 [default]
    [NEW] Device 00:18:91:38:E0:E7 BTHS600
    [NEW] Device C8:84:47:0F:01:59 (59)Logitech Adapter
    [bluetooth]# info 00:18:91:38:E0:E7
    Device 00:18:91:38:E0:E7
    	Name: BTHS600
    	Alias: BTHS600
	Class: 0x240404
	Icon: audio-card
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: yes
	UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)

(NB the button on the headset also worked as a play/pause media key on F19 and does nothing on F20, so I guess "A/V Remote Control" is also not working…).

I tried & failed to use sdptool (after `hcitool cc`) to verify if this is related to bug 1019509:

    carl@hostname:[~]$ sdptool browse 00:18:91:38:E0:E7
    Browsing 00:18:91:38:E0:E7 ...
    carl@hostname:[~]$

Comment 2 Brian J. Murrell 2014-01-05 06:56:06 UTC
Ditto here.

[bluetooth]# info 50:C9:71:83:EC:70
Device 50:C9:71:83:EC:70
	Name: Jabra EXTREME2 v4.14.0
	Alias: Jabra EXTREME2 v4.14.0
	Class: 0x240404
	Icon: audio-card
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Serial Port               (00001101-0000-1000-8000-00805f9b34fb)
	UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb)
	UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
	UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
	Modalias: usb:v0B0EpABCDd040E

Yet in the pulseaudio volume control->Configuration I only have "Off" and "High Fidelity Playback (A2DP Sink)" as choices.

Comment 3 Jonathan Kamens 2014-01-06 15:06:13 UTC
Apparently this is now the responsibility of pulseaudio.

Sure would be nice if the maintainer of bluez tickets in Bugzilla had reassigned the ticket in the 17 days since I filed it.

<soapbox>I can't tell you how wonderful it makes me feel that Fedora has once again put out a new release with major regressions in significant functionality without anyone seeming to care about or even acknowledge feedback from users about it.</soapbox>

Comment 4 Brian J. Murrell 2014-01-06 15:25:20 UTC
(In reply to Jonathan Kamens from comment #3)
> 
> Sure would be nice if the maintainer of bluez tickets in Bugzilla had
> reassigned the ticket in the 17 days since I filed it.

Yeah.  I have been finding the lack of attention paid to tickets in bugzilla by maintainers to be frustrating also.

But this being a pulseaudio issue does not bode well either.  I have found that pulseaudio tickets in the RH bugzilla get the same lack of attention.

This issue probably needs to be raised upstream to get any kind of activity on it.
 
> <soapbox>I can't tell you how wonderful it makes me feel that Fedora has
> once again put out a new release with major regressions in significant
> functionality without anyone seeming to care about or even acknowledge
> feedback from users about it.</soapbox>

Yeah.  F20 is the first release in many where the issues have been so grave that I have had to revert back to F19.  In fact I've had to do that a number of times with this F20 between multiple show-stopper level GTK bugs and now this Bluetooth issue -- these are all issues where there is no suitable workaround and waiting (and suffering) for a bug fix is just too painful.

Comment 5 Brian J. Murrell 2014-01-06 15:32:32 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=73325

Comment 6 Carl van Tonder 2014-01-06 15:41:01 UTC
F20 feature page:

http://fedoraproject.org//wiki/Changes/Bluez5

Last QA discussion I can find:

https://fedoraproject.org/wiki/QA/Meetings/20130722

Draft PA 5.0 release notes:

http://www.freedesktop.org/wiki/Software/PulseAudio/Notes/5.0/



The Bluez5 feature could have been delayed (enacting the "Contingency plan" listed on the wiki). Failing that, this was a known regression and should have been added to the release notes. I have added comments saying so to bug 998563 (tracker bug for Bluez5 feature) and bug 1001338 (release notes change for Bluez5).


Mystified as to how a documented regression escaped the notice of the intelligent people working on this (Rex Dieter & Kalev Lember who packaged the new Pulseaudio or Bastien Nocera who is listed as an owner of the Bluez5 feature).

Comment 7 Rex Dieter 2014-01-06 15:44:40 UTC
fwiw, I'm largely involved in pulseaudio packaging issues only.  In particular, during f20 development, was not involved much in testing the bluez5 feature (largely due to not having access to testable Bluetooth devices at the time).

Comment 8 Mike Ruckman 2014-01-06 19:16:26 UTC
Adding this to the F20 Common Bugs page. [1]

[1] https://fedoraproject.org/wiki/Common_F20_bugs#bluez5-profile

Comment 9 Adam Williamson 2014-01-11 00:51:38 UTC
Mike: when you add a bug to the commonbugs page, stick the shortlink to it in the Whiteboard field, or else it'll show up in the CommonBugs? search rather than the CommonBugs+ search. thanks!

Comment 10 Brian J. Murrell 2014-01-22 12:50:08 UTC
Is this something that is likely to be resolved in the F20 time frame or should I just stop checking for this to be fixed and give up hope on being able to use F20?

If it's not going to be fixed in F20, that fine (well, not fine, but there's nothing I can do to change it) but please just let us know so that we can adjust our expectations accordingly.  Thanks.

Comment 11 Rex Dieter 2014-01-22 13:05:09 UTC
It's all dependent on when the missing feature is implemented in pulseaudio upstream (per comment #6). I'm not aware of anyone downstream (in fedora) working on this currently.

Comment 12 David Sommerseth 2014-01-23 15:46:30 UTC
Can we please consider to downgrade to bluez4 ASAP until this is fixed?  This is directly hurting my work situation, and I doubt I'm the only one.

Are there more packages than gnome-bluetooth and pulseaudio which needs to be recompiled?

I'm willing to test this, and even spin some builds if someone leads me in the right direction.

Comment 13 Rex Dieter 2014-01-23 15:51:44 UTC
http://fedoraproject.org/wiki/Changes/Bluez5

outlines most of the changes that would need undoing.


That said, doing so officially (as well as continued discussion in bugzilla on the topic) would be impractical, imho.  there are other venues much better suited, probably -devel list, if you want to to followup.

Comment 14 David Sommerseth 2014-01-23 18:55:03 UTC
(In reply to Rex Dieter from comment #13)
>
> That said, doing so officially (as well as continued discussion in bugzilla
> on the topic) would be impractical, imho.  there are other venues much
> better suited, probably -devel list, if you want to to followup.

Sure, no problem.  Thread started:
http://thread.gmane.org/gmane.linux.redhat.fedora.devel/191283

Comment 15 Brian J. Murrell 2014-04-25 11:28:23 UTC
Is this planned to be fixed for F21?

Comment 16 Rex Dieter 2014-04-25 12:16:11 UTC
The pulseaudio upstream bug tracking this currently has this feature targetting pulseaudio-6.0 release.  I'm not privy to their precise development schedule/plans, but pretty sure that should land prior to f21 release.

Comment 17 Dan Varga 2014-06-12 13:42:51 UTC
Does anyone have a workaround?  I just purchased a new headset and ran into this, rather frustrating.

Comment 18 Brian J. Murrell 2014-06-12 18:10:23 UTC
(In reply to Dan Varga from comment #17)
> Does anyone have a workaround?  I just purchased a new headset and ran into
> this, rather frustrating.

The only known workaround (that I know of) is to go out and buy a wired headset (and possibly sound card to plug it into).

Comment 19 Brian J. Murrell 2014-07-08 11:46:36 UTC
So, per https://bugs.freedesktop.org/show_bug.cgi?id=73325 it looks like this is going to miss F21 also.

This seems like a pretty serious regression to miss a second release.

Comment 20 Netbulae 2014-07-08 12:22:18 UTC
So we'll have to switch to another distro for our workstations. This is a critical issue for our internal communication and we can't wait another half/full year.

Bummer  :-<

Comment 21 David Caro 2014-07-17 11:24:56 UTC
Having the same issue with this headset:

dcaro@brete$ bluetoothctl
[NEW] Controller E0:06:E6:B8:58:A4 brete-0 [default]
[NEW] Device 00:12:D0:11:78:D4 EP650
[bluetooth]# info 00:12:D0:11:78:D4
Device 00:12:D0:11:78:D4
	Name: EP650
	Alias: EP650
	Class: 0x240404
	Icon: audio-card
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
	UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)

Comment 22 Mete B. 2014-07-18 08:42:33 UTC
And also with this headset:

[bluetooth]# info 20:13:04:18:57:78
Device 20:13:04:18:57:78
	Name: SPEEDLINK TRACTS
	Alias: SPEEDLINK TRACTS
	Class: 0x240404
	Icon: audio-card
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)

Comment 23 Jonathan Kamens 2014-07-18 08:45:28 UTC
It's broken with EVERY headset. Please stop posting comments about specific headset. They're just clutter.

Comment 24 Wim Taymans 2014-07-18 12:40:13 UTC
(In reply to Netbulae from comment #20)
> So we'll have to switch to another distro for our workstations. This is a
> critical issue for our internal communication and we can't wait another
> half/full year.
> 

You would have to switch to a distro that still wants to ship the unmaintained bluez4. You could just as well wait a little longer and stick with Fedora 19. I plan to look at this later.

Comment 25 Mauro Carvalho Chehab 2014-10-22 02:04:52 UTC
Created attachment 949217 [details]
Backport HSP patches from pulseaudio upstream

Pulseaudio received some patches for HSP/HFP. Backport them to Fedora 20.

Now that upstream received patches for Headsets, backport them on Pulseaudio.

With this patch, I'm now being able to see not only A2DP, but also HSP/HDP with my Bluetooth SoundBot SB235 phone.

Still, pavucontrol doesn't show SB235 mic as an input device. I guess something else is needed for headset devices to be fully operational with Bluez5/PA.

Comment 26 Brian J. Murrell 2014-10-22 11:05:38 UTC
While comment #25 is somewhat encouraging ...

(In reply to Wim Taymans from comment #24)
> 
> You could just as well wait a little longer and stick
> with Fedora 19.

... does this mean F21?  It seems to me that "wait a little longer" surely can't mean F22.  I think waiting 3 releases is waiting more than "a little" longer.

Comment 27 Netbulae 2014-10-22 11:36:55 UTC
I must agree with Wim! It shouldn't be that hard, if it is there is something seriously wrong with the audio maintainers.

We like to use Fedora as workstation and this involves communication.

If we all would like to stick to F19, we would run Rhel on the notebook....

Comment 29 Lubomir Rintel 2014-10-22 12:30:07 UTC
14:26 < diwic> lubko, no, but it will be available in PA 6.0
14:27 < diwic> lubko, which, hopefully, is happening soonish.
14:27 < diwic> lubko, and it's only the ofono backend which has landed
14:27 < diwic> lubko, we're waiting for the native backen to land too

words from upstream

Comment 30 Rex Dieter 2014-10-22 13:00:39 UTC
I'll build a pulseaudio snapshot for testing

Comment 31 Rex Dieter 2014-10-22 22:03:27 UTC
%changelog
* Wed Oct 22 2014 Rex Dieter <rdieter@fedoraproject.org> 5.0-21.20141007git4971d
- BR: automake libtool (for bootstrap.sh)

* Wed Oct 22 2014 Rex Dieter <rdieter@fedoraproject.org> 5.0-20.20141007git4971d
- snapshot, with wip bt headset2 patches (#1045548,#1067470)


pulseaudio-5.0-21.20141007git4971d built for rawhide, and f20/f21 scratch builds included in
https://repos.fedorapeople.org/repos/rdieter/pulseaudio-backport/
for testing

Comment 32 Jonathan 2014-10-23 02:50:26 UTC
Tested F20 with Sony SBH20 headset.
Good: In soundsettings, the headset now have the optional profile HSP/HFP
      Under input, the headset microphone is now available.

Bad:  The microphone volume is very low. It might need some boost?
      Setting output - profile to A2DP creates a duplicate line with the headset under the output tab, and this can be repeated for any number of duplicate lines.

Comment 33 Jonathan Kamens 2014-10-23 02:54:45 UTC
(In reply to Jonathan from comment #32)
>       Setting output - profile to A2DP creates a duplicate line with the
> headset under the output tab, and this can be repeated for any number of
> duplicate lines.

This is bug 983298.

Comment 34 Brian J. Murrell 2014-10-23 11:43:15 UTC
(In reply to Rex Dieter from comment #31)
> 
> pulseaudio-5.0-21.20141007git4971d built for rawhide, and f20/f21 scratch
> builds included in
> https://repos.fedorapeople.org/repos/rdieter/pulseaudio-backport/
> for testing

So yeah.  This does seem to work with my BT HSP/HFP headset.

And it's seeing my "DSP55" USP sound card but it's not seeing my built-in sound hardware:

$ cat /proc/asound/cards 
 0 [MID            ]: HDA-Intel - HDA Intel MID
                      HDA Intel MID at 0xf2620000 irq 56
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xcdefc000 irq 16
 2 [Adapter        ]: USB-Audio - DSP55 Adapter
                      Plantronics DSP55 Adapter at usb-0000:00:1a.0-1.2, full speed
29 [ThinkPadEC     ]: ThinkPad EC - ThinkPad Console Audio Control
                      ThinkPad Console Audio Control at EC reg 0x30, fw 6MHT43WW-1.18

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: CX20585 Analog [CX20585 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Adapter [DSP55 Adapter], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Is this a regression or some kind of additional configuration needed that I am not aware of?  I will attach the output of "pulseaudio -vvvv" in case you are interested in looking further.

Comment 35 Brian J. Murrell 2014-10-23 11:44:29 UTC
Created attachment 949822 [details]
pulseaudio -vvvv log

Comment 36 Brian J. Murrell 2014-10-23 12:09:50 UTC
I seemed to resolve my issue with this PA snapshot not seeing my built-in hardware.  I had to:

# ln -s default.conf /usr/share/pulseaudio/alsa-mixeprofile-sets/extra-hdmi.conf

Comment 37 Leif Liddy 2014-10-25 16:58:03 UTC
Tested F20 with Sony MDR-1RBT headphones.

Working: Can select HSP/HFP profile
Microphone works and volume is perfect  
**There are no duplicate headset lines

Not working: When I select the A2DP profile, it doesn't actually active it. The selection of the A2DP profile isn't persistent either. Closing the sound settings window and reopening it or clicking on "Test Speakers" causes the profile selection to revert back to HSP/HFP.

Comment 38 Leif Liddy 2014-10-26 00:38:47 UTC
When I disconnected and reconnected the headphones, both AD2P and HSP/HFP modes worked correctly. In gnome, I'm now seeing duplicate headset entries in the sound settings window. However, this issue is gnome-specific as I don't see duplicate entries in the cinnamon sound settings window (when using cinnamon desktop).

Comment 39 Fedora Update System 2014-11-06 18:10:17 UTC
pulseaudio-5.0-23.20141103gitaec81.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pulseaudio-5.0-23.20141103gitaec81.fc21

Comment 40 Mete B. 2014-11-10 11:19:59 UTC
(In reply to Rex Dieter from comment #31)
> %changelog
> * Wed Oct 22 2014 Rex Dieter <rdieter@fedoraproject.org>
> 5.0-21.20141007git4971d
> - BR: automake libtool (for bootstrap.sh)
> 
> * Wed Oct 22 2014 Rex Dieter <rdieter@fedoraproject.org>
> 5.0-20.20141007git4971d
> - snapshot, with wip bt headset2 patches (#1045548,#1067470)
> 
> 
> pulseaudio-5.0-21.20141007git4971d built for rawhide, and f20/f21 scratch
> builds included in
> https://repos.fedorapeople.org/repos/rdieter/pulseaudio-backport/
> for testing

works fine. No problems !

Comment 41 Gabriele Turchi 2014-11-10 17:10:55 UTC
(In reply to Rex Dieter from comment #31)
> %changelog
> * Wed Oct 22 2014 Rex Dieter <rdieter@fedoraproject.org>
> 5.0-21.20141007git4971d
> - BR: automake libtool (for bootstrap.sh)
> 
> * Wed Oct 22 2014 Rex Dieter <rdieter@fedoraproject.org>
> 5.0-20.20141007git4971d
> - snapshot, with wip bt headset2 patches (#1045548,#1067470)
> 
> 
> pulseaudio-5.0-21.20141007git4971d built for rawhide, and f20/f21 scratch
> builds included in
> https://repos.fedorapeople.org/repos/rdieter/pulseaudio-backport/
> for testing


Mhhh... On F20, x86_64, yum returns a multilib error. I duplicated the repo entry in the config file, giving access also to i386 version. Now yum likes it, but I'm not sure that this is the right way to proceed: the pulseaudio-libs rpms are really multilib compatible?

Comment 42 Rex Dieter 2014-11-10 17:30:05 UTC
That repo should be multilib'd right, mind sending me the conflicts error details privately?

Comment 43 Adam Huffman 2014-11-12 11:03:39 UTC
Hmm. Those builds haven't fixed it for me. I can't even associate with my headset - or rather, it's connected for a few seconds then disappears. That appears to be a kernel problem, which may be unrelated.

Comment 44 Rex Dieter 2014-11-12 12:47:48 UTC
Unfortunately, the update for this issue,
https://admin.fedoraproject.org/updates/FEDORA-2014-14476
(pulseaudio-5.0-24.20141103gitaec81.fc21)
has been revoked due to other problems/regressions (namely bug #1161883)

You can run,
yum distro-sync
to downgrade to the last known-good release in stable updates (pulseaudio-5.0-10)


(The pulseaudio-backport repo will continue to track newer builds as testing continues)

Comment 45 Netbulae 2014-11-12 14:35:44 UTC
Plantronics headset works perfectly now, after a reinstall of pulseaudio packages and a reboot. 

Before the reinstall and/or reboot all audio devices were messed up.

We also have the other bug now as mentioned above.

Comment 46 Jonathan Kamens 2014-11-12 22:34:54 UTC
(In reply to Adam Huffman from comment #43)
> Hmm. Those builds haven't fixed it for me. I can't even associate with my
> headset - or rather, it's connected for a few seconds then disappears. That
> appears to be a kernel problem, which may be unrelated.

Maybe this is bug 1045546?

Comment 47 Fedora Update System 2014-11-14 16:10:46 UTC
pulseaudio-5.0-25.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pulseaudio-5.0-25.fc21

Comment 48 Fedora Update System 2014-11-15 09:21:36 UTC
Package pulseaudio-5.0-25.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pulseaudio-5.0-25.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15132/pulseaudio-5.0-25.fc21
then log in and leave karma (feedback).

Comment 49 Ingo Weiss 2014-11-18 20:38:26 UTC
Just tested on a ThinkPad X201, Fedora 21 and a Jabra Classic. Everything is working perfectly fine. Audio output and input work without issues.

Comment 50 Fedora Update System 2014-11-22 00:45:57 UTC
pulseaudio-5.0-25.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 51 Zamir SUN 2014-12-20 16:42:50 UTC
Hi, will this fix backport to Fedora 20?

Comment 52 Fedora Update System 2014-12-22 17:19:54 UTC
pulseaudio-5.0-25.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pulseaudio-5.0-25.fc20

Comment 53 Brian J. Murrell 2015-01-05 22:34:49 UTC
So is this supposed to be working in F21?  My headset is seen by both bluetoothctl and Pulseaudio and PA has an HSP/HFP profile for it but I still don't get an Input device for it.

Here's what bluetoothctl shows:

[bluetooth]# info 50:C9:71:83:xx:yy
Device 50:C9:71:83:xx:yy
	Name: Jabra EXTREME2 v4.14.0
	Alias: Jabra EXTREME2 v4.14.0
	Class: 0x240404
	Icon: audio-card
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb)

Comment 54 Fedora Update System 2015-01-08 23:30:13 UTC
pulseaudio-5.0-25.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 55 pavel.nedr 2016-02-23 14:51:18 UTC
Still having this trouble in fedora 22:
$ bluetoothctl
[NEW] Device AC:9B:0A:18:23:56 MDR-ZX770BT
[bluetooth]# info AC:9B:0A:18:23:56
Device AC:9B:0A:18:23:56
        Name: MDR-ZX770BT
        Alias: MDR-ZX770BT
        Class: 0x240404
        Icon: audio-card
        Paired: yes
        Trusted: yes
        Blocked: no
        Connected: yes
        LegacyPairing: no
        UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
        UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
        UUID: Advanced Audio Distribu.. (0000110d-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
        UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)

It doesn't work on any of my bluetooth devices (Jabra, Sony, Logitech).
But it works, for example, with my Android phone.

Comment 56 Kevin R. Page 2016-03-11 09:23:12 UTC
Reporter/maintainer: Please re-open and change version to 23.

As with comment #55 my headset now shows with a selector for A2DP or HFP/HSP, but when the latter is selected there's no microphone input, nor is it in control panel.

$ bluetoothctl 
[NEW] Controller E8:2A:EA:30:FC:9F wordsworth [default]
[NEW] Device 00:0D:44:A6:D1:B2 Logitech Wireless Headset
[NEW] Device 00:08:E0:39:6C:B0 QED uPlay
[bluetooth]# info 00:0D:44:A6:D1:B2
Device 00:0D:44:A6:D1:B2
	Name: Logitech Wireless Headset
	Alias: Logitech Wireless Headset
	Class: 0x240404
	Icon: audio-card
	Paired: yes
	Trusted: yes
	Blocked: no
	Connected: yes
	LegacyPairing: no
	UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
	UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
	UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
	UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)

Headset is a Logitech as per bug #1019509

Comment 57 Rex Dieter 2016-03-11 13:09:33 UTC
I'd encourage a new bug (vs re-opening), this one was used to track f20/f21-specific issues

Comment 58 pavel.nedr 2016-03-11 14:07:16 UTC
@Rex Dieter, there is two related bugs for actual Fedora 23 and RHEL 7: https://bugzilla.redhat.com/show_bug.cgi?id=1305453 and https://bugzilla.redhat.com/show_bug.cgi?id=1311238


Note You need to log in before you can comment on or make changes to this bug.