Bug 1019598 - [RHS-C] Status of the volume in activities column after Stop rebalance should be in sync with gluster CLI output
[RHS-C] Status of the volume in activities column after Stop rebalance should...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Ramesh N
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 02:48 EDT by Shubhendu Tripathi
Modified: 2015-05-13 12:29 EDT (History)
9 users (show)

See Also:
Fixed In Version: Cb6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:52:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attaching stop rebalance error dialog. (172.04 KB, image/png)
2013-11-14 08:24 EST, RamaKasturi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20524 None None None Never
Red Hat Product Errata RHEA-2014:0208 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 07:20:30 EST

  None (edit)
Description Shubhendu Tripathi 2013-10-16 02:48:38 EDT
Description of problem:
The icon shown in the activities column of the volume after stop rebalance should reflect the actual status of the activity and should be in sync with the gluster CLI output.

Sometimes, even if the rebalance was completed when stop was fired, the activities column shows as stopped whereas if the status is invoked it shows correctly as completed in the status dialog.

The activities column should reflect the correct status of the activity.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to Volumes tab and select a volume from the list
2. Start rebalance by clicking the "Rebalance" menu option
3. Wait for sometime and click the "Stop" from drop down menu option in activities column

Actual results:
The activities column icon changes to stopped whereas the activities got finished by the time stop was fired.

Expected results:
If the activity got finished by the time stop was fired, the same should be reflected in volume activities column as well.

Additional info:
Comment 2 RamaKasturi 2013-10-29 09:20:14 EDT
The above happens when glusterd is made down and rebalance is started, wait for some time and click on rebalance stop it actually stops rebalance and tasks pane shows that task is aborted.
Comment 3 RamaKasturi 2013-11-14 08:23:52 EST
The above happens when glusterd is made down and rebalance is started, wait for some time and click on rebalance stop it actually stops rebalance and tasks pane shows that task is aborted.

In the above scenario it gives the error attached in the "stoprebalance".

This can be verified only when the following BZ : 1015045 is fixed.
Comment 4 RamaKasturi 2013-11-14 08:24:28 EST
Created attachment 823945 [details]
Attaching stop rebalance error dialog.
Comment 5 RamaKasturi 2013-12-16 07:18:18 EST
verified and works fine in cb11 rhsc-2.1.2-0.27.beta.el6_5.noarch.

When rebalance completes on all the nodes and clicked on stop button, it updates the icon as completed.

when glusterd is made down and clicked on stop button, it updates the icon as failed.
Comment 6 Ramesh N 2014-01-03 03:40:24 EST
Doc Text is not required  as its a new feature and we already have an RFE
Comment 8 errata-xmlrpc 2014-02-25 02:52:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.