Bug 1019626 - [engine-backend] A disk isn't activated automatically when attaching it to a vm
[engine-backend] A disk isn't activated automatically when attaching it to a vm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Ayal Baron
Leonid Natapov
storage
:
Depends On: 1015683 1029605
Blocks: 3.3snap4
  Show dependency treegraph
 
Reported: 2013-10-16 03:35 EDT by Elad
Modified: 2016-02-10 15:27 EST (History)
12 users (show)

See Also:
Fixed In Version: is26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: Triaged+


Attachments (Terms of Use)
screenshot (31.65 KB, image/png)
2013-10-16 03:35 EDT, Elad
no flags Details
vdsm+enigne logs (1.34 MB, application/x-gzip)
2013-10-17 10:39 EDT, Elad
no flags Details

  None (edit)
Description Elad 2013-10-16 03:35:44 EDT
Created attachment 812791 [details]
screenshot

Description of problem:
When importing a new image from glance and attaching it to vm, the disk is not activated automatically like regular disk.

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.25.beta1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. add new external provider to RHEVM (glance images)
2. import an image from glance to rhevm
3. create a new vm and attach the new imported disk

Actual results:
The new imported disk is not activated when attaching it to a vm.

Expected results:
The new imported disk should be activated when attaching it to a vm like a regular disk.

Additional info: screenshot
Comment 1 Allon Mureinik 2013-10-17 10:30:58 EDT
Please attach the logs (engine+vdsm)
Comment 2 Elad 2013-10-17 10:39:11 EDT
Created attachment 813359 [details]
vdsm+enigne logs
Comment 3 Daniel Erez 2013-11-12 08:47:06 EST
Caused by lack of no-arg constructor in AttachDettachVmDiskParameters class
(GWT 2.5 serialization issues).
Already fixed by http://gerrit.ovirt.org/#/c/18908/
Comment 4 Allon Mureinik 2013-11-13 02:16:25 EST
Daniel, Einav - bug 1029605 seems like it may take a while, and we want to enable QA to test Glance flows.

http://gerrit.ovirt.org/#/c/18908/ Seems quite straight forward, and a good idea to merge on the 3.3 branch regardless of the rest of the fix for 1029605.
Can we backport it and move THIS bug to MODIFIED?
Comment 5 Einav Cohen 2013-11-13 07:25:25 EST
(In reply to Allon Mureinik from comment #4)
> Daniel, Einav - bug 1029605 seems like it may take a while, and we want to
> enable QA to test Glance flows.
> 
> http://gerrit.ovirt.org/#/c/18908/ Seems quite straight forward, and a good
> idea to merge on the 3.3 branch regardless of the rest of the fix for
> 1029605.
> Can we backport it and move THIS bug to MODIFIED?

Hi Alon, we intend to backport all 3 patches associated with bug 1029605 to ovirt-engine-3.3, but I wanted to do backport all of them together, once all are merged to 'master' (although we indeed don't have to wait for that in order to backport the specific one that you mentioned).

while we are at it: any chance for a re-review on http://gerrit.ovirt.org/#/c/20274/?
Comment 6 Allon Mureinik 2013-11-27 04:55:47 EST
Moved to MODIFIED since bug 1029605 is now MODIFIED too, in order for QA to validate once there's a build.
Comment 7 Ayal Baron 2013-11-27 05:40:57 EST
(In reply to Allon Mureinik from comment #6)
> Moved to MODIFIED since bug 1029605 is now MODIFIED too, in order for QA to
> validate once there's a build.

Just putting on ON_QA with fixed in version - is26 (next build which will include the relevant patches)
Comment 8 Elad 2013-12-15 03:37:24 EST
A disk which was originally imported as a glance image, is being activated automatically when attaching it to VM.

Verified using is26
Comment 9 Elad 2013-12-15 03:37:54 EST
A disk which was originally imported as a glance image, is being activated automatically when attaching it to VM.

Verified using is26
Comment 10 Itamar Heim 2014-01-21 17:21:51 EST
Closing - RHEV 3.3 Released
Comment 11 Itamar Heim 2014-01-21 17:27:07 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.