Bug 1019818 - Support OpenStack Havana layer 2 agent integration
Support OpenStack Havana layer 2 agent integration
Status: CLOSED CURRENTRELEASE
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.OpenStack (Show other bugs)
---
x86_64 Linux
unspecified Severity high (vote)
: ---
: 1.2.0
Assigned To: Mike Kolesnik
yeylon@redhat.com
network
: Improvement
Depends On:
Blocks: 1032890
  Show dependency treegraph
 
Reported: 2013-10-16 09:01 EDT by Assaf Muller
Modified: 2016-04-18 02:52 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-3.3.3-beta1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1032890 (view as bug list)
Environment:
Last Closed: 2014-02-14 04:56:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt-host-deploy log with failed attempt to modify /etc/quantum/quantum.conf (1.76 KB, text/plain)
2013-10-16 09:01 EDT, Assaf Muller
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21491 None None None Never

  None (edit)
Description Assaf Muller 2013-10-16 09:01:00 EDT
Created attachment 812909 [details]
ovirt-host-deploy log with failed attempt to modify /etc/quantum/quantum.conf

Description of problem:
If external Neutron provider is selected during new host install, then When ovirt-host-deploy attempts to install the layer 2 agent it uses "quantum" instead of "neutron". Havana changed the path of configuration files and such to use neutron.

Version-Release number of selected component (if applicable):
oVirt 3.3 from master

How reproducible:
100%

Steps to Reproduce:
1. Add new host with external Neutron provider

Actual results:
New host install fails when trying to install layer 2 agent. Attached logs.

Expected results:
New host install should succeed.
Comment 1 Alon Bar-Lev 2013-10-16 09:04:03 EDT
A patch will be welcomed.
Comment 2 Assaf Muller 2013-10-16 09:05:18 EDT
Possible solutions / implications: Currently we "support" Neutron integration with Grizzly where the name was still quantum. Havana changed the name to neutron. Should we just move to support havana? Does this have release notes implications? Should we add a select box to the GUI when adding a host instead?
Comment 3 Dan Kenigsberg 2013-10-18 18:14:04 EDT
We cannot just drop the support for Grizzly during the ovirt-3.3 lifetime. So we should support both Grizzly and Havana.

I see no reason to add a UI checkbox: ovirt-host-deploy should handle whatever version is available at the host. If Engine must know the version installed on the host, Vdsm should report it.
Comment 4 Alon Bar-Lev 2013-10-19 02:42:31 EDT
As far as I know, openstack is  not 'supported' it is 'release preview', in other words it is 'experimental'. I see no problem to require newer openstack component at any stage.
Comment 5 Dan Kenigsberg 2013-10-19 09:03:47 EDT
Ok, it makes sense to use the benefits of being a "tech preview".
Comment 6 Sandro Bonazzola 2013-11-28 10:33:52 EST
Re-targeting to 3.3.3 since the bug is not resolved in 3.3.2 beta and is not blocking 3.3.2 release tracker (bug #1027349)
Comment 8 Sandro Bonazzola 2014-02-14 04:56:42 EST
Closing as 3.3.3 has been released.

Note You need to log in before you can comment on or make changes to this bug.