Bug 1032890 - [RHEV][host deploy] Support OpenStack Havana layer 2 agent integration
[RHEV][host deploy] Support OpenStack Havana layer 2 agent integration
Status: CLOSED ERRATA
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.OpenStack (Show other bugs)
---
x86_64 Linux
high Severity high (vote)
: ---
: 1.1.2
Assigned To: Mike Kolesnik
Meni Yakove
network
: Improvement, Triaged
Depends On: 1019818
Blocks: 3.3rc1
  Show dependency treegraph
 
Reported: 2013-11-21 02:31 EST by Mike Kolesnik
Modified: 2016-02-10 14:49 EST (History)
14 users (show)

See Also:
Fixed In Version: is27
Doc Type: Bug Fix
Doc Text:
If the external Neutron provider was selected during a new host install, when ovirt-host-deploy attempted to install the layer 2 agent it used "quantum" instead of "neutron". OpenStack Havana changed the path of the configuration files and such to use neutron. To fix this quantum has been renamed to neutron in all references to packages and configuration files in order to support the new naming scheme.
Story Points: ---
Clone Of: 1019818
Environment:
Last Closed: 2014-01-21 10:57:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: blocker+
masayag: devel_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21491 None None None Never
oVirt gerrit 21494 None None None Never
oVirt gerrit 22069 None None None Never

  None (edit)
Description Mike Kolesnik 2013-11-21 02:31:03 EST
+++ This bug was initially created as a clone of Bug #1019818 +++

Description of problem:
If external Neutron provider is selected during new host install, then When ovirt-host-deploy attempts to install the layer 2 agent it uses "quantum" instead of "neutron". Havana changed the path of configuration files and such to use neutron.

Version-Release number of selected component (if applicable):
oVirt 3.3 from master

How reproducible:
100%

Steps to Reproduce:
1. Add new host with external Neutron provider

Actual results:
New host install fails when trying to install layer 2 agent. Attached logs.

Expected results:
New host install should succeed.

--- Additional comment from Alon Bar-Lev on 2013-10-16 09:04:03 EDT ---

A patch will be welcomed.

--- Additional comment from Assaf Muller on 2013-10-16 09:05:18 EDT ---

Possible solutions / implications: Currently we "support" Neutron integration with Grizzly where the name was still quantum. Havana changed the name to neutron. Should we just move to support havana? Does this have release notes implications? Should we add a select box to the GUI when adding a host instead?

--- Additional comment from Dan Kenigsberg on 2013-10-18 18:14:04 EDT ---

We cannot just drop the support for Grizzly during the ovirt-3.3 lifetime. So we should support both Grizzly and Havana.

I see no reason to add a UI checkbox: ovirt-host-deploy should handle whatever version is available at the host. If Engine must know the version installed on the host, Vdsm should report it.

--- Additional comment from Alon Bar-Lev on 2013-10-19 02:42:31 EDT ---

As far as I know, openstack is  not 'supported' it is 'release preview', in other words it is 'experimental'. I see no problem to require newer openstack component at any stage.

--- Additional comment from Dan Kenigsberg on 2013-10-19 09:03:47 EDT ---

Ok, it makes sense to use the benefits of being a "tech preview".
Comment 2 Meni Yakove 2013-12-15 08:42:47 EST
rhevm-3.3.0-0.40.rc.el6ev.noarch
Comment 3 errata-xmlrpc 2014-01-21 10:57:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0074.html

Note You need to log in before you can comment on or make changes to this bug.