Bug 1019821 - Xdmx mouse after button-click goes to upper-left position
Xdmx mouse after button-click goes to upper-left position
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1022348
  Show dependency treegraph
 
Reported: 2013-10-16 09:04 EDT by Caolan McNamara
Modified: 2013-10-28 23:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.14.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1022348 (view as bug list)
Environment:
Last Closed: 2013-10-28 23:47:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 63486 None None None Never

  None (edit)
Description Caolan McNamara 2013-10-16 09:04:30 EDT
Description of problem:
Xdmx mouse after button-click goes to 0,0

Version-Release number of selected component (if applicable):
xorg-x11-server-Xdmx-1.14.3-1.fc19.x86_64

How reproducible:


Steps to Reproduce:
1. Xephyr -screen 640x480 -ac :1 &
2. Xephyr -screen 640x480 -ac :2 &
3. Xdmx +xinerama -xinput local -display :1 -display :2 -ac :4 &
4. export DISPLAY=:4.0
5. twm &
6. left click in screen 1

Actual results:

mouse warps to 0,0 and menu appears there


Expected results:
menu should appear under the mouse


Additional info:
https://bugs.freedesktop.org/show_bug.cgi?id=63486 with reported fix sounds like this
Comment 1 Peter Hutterer 2013-10-23 02:07:38 EDT
Verified upstream, present since at least server 1.13.0
Comment 2 Fedora Update System 2013-10-23 17:49:46 EDT
xorg-x11-server-1.14.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.14.3-2.fc19
Comment 3 Fedora Update System 2013-10-24 21:53:31 EDT
Package xorg-x11-server-1.14.3-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.14.3-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19900/xorg-x11-server-1.14.3-2.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-10-28 23:47:00 EDT
xorg-x11-server-1.14.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.