Bug 1022348 - Xdmx mouse after button-click goes to upper-left position
Xdmx mouse after button-click goes to upper-left position
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Peter Hutterer
Desktop QE
:
Depends On: 1019821
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 02:11 EDT by Peter Hutterer
Modified: 2015-01-07 20:16 EST (History)
4 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.15.0-22.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1019821
Environment:
Last Closed: 2015-01-07 20:16:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 63486 None None None Never

  None (edit)
Description Peter Hutterer 2013-10-23 02:11:29 EDT
+++ This bug was initially created as a clone of Bug #1019821 +++

Description of problem:
Xdmx mouse after button-click goes to 0,0

Version-Release number of selected component (if applicable):
xorg-x11-server-Xdmx-1.14.3-1.fc19.x86_64

How reproducible:


Steps to Reproduce:
1. Xephyr -screen 640x480 -ac :1 &
2. Xephyr -screen 640x480 -ac :2 &
3. Xdmx +xinerama -xinput local -display :1 -display :2 -ac :4 &
4. export DISPLAY=:4.0
5. twm &
6. left click in screen 1

Actual results:

mouse warps to 0,0 and menu appears there


Expected results:
menu should appear under the mouse


Additional info:
https://bugs.freedesktop.org/show_bug.cgi?id=63486 with reported fix sounds like this

--- Additional comment from Peter Hutterer on 2013-10-23 02:07:38 EDT ---

Verified upstream, present since at least server 1.13.0
Comment 2 Peter Hutterer 2013-10-23 18:52:27 EDT
confirmed on xorg-x11-server-1.13.0-23.el6
Comment 6 Peter Hutterer 2015-01-07 19:45:33 EST
Upstream commit e16dea72d6f45dd6d7788362bb7dbe76263719b1
Comment 7 Peter Hutterer 2015-01-07 20:16:15 EST
This fix was merged into the upstream 1.15 and is available since the RHEL 6.6 Xorg rebase. No further fixes are necessary.


xorg-x11-server-1.15.0-22.el6 and later

Note You need to log in before you can comment on or make changes to this bug.